Open main menu

Wikibooks β

Toolbox from GIMP 2.6

GIMP has a "toolbox" to quickly perform basic tasks. Toolbox is customizable, this means that you can add / remove any tool you want. To select tools for doing something, go to the "Tools" menu, and select any tool you want. To put the tool on the panel go to "Edit > Preferences > Toolbox".

But it can only be edited in a linear way, that is, while sorting it in the "options" there's no way to see where tools will finally appear on the grid. Even though the program's layout updates instantly. They push each other around. There's no way to align tools to right or other corners, or each other.

If the user later shifts the width of the toolbox' panel (to optimize space on screen), the grid gets misaligned, so there's a way to accommodate only 1 layout. If leaving a not evenly divisible quantity of tools, the lowest-right corner can't be utilized.

For that matter, it may be useful to make a screenshot of the toolbox with having activated all the needed tools, and lay out the grid in an easy raster program like Paint or GIMP itself, to make the surface look the needed way. Then start moving them in Preferences accordingly. Remember that tools go from the up-left corner, rightwise then down.


By default not all tools are shown - for example GEGL operation and colour tools are omitted. All tools can also be accessed by opening the "Tools" menu. To switch the window to toolbox, you can use Ctrl + B. Shortcuts written here are the default values - you can change them any time in "Edit > Keyboard Shortcuts" or "Edit > Preferences > Keyboard Shortcuts".

More sophisticated tools are not in the toolbox, but next to the Tools, in the Filters menu.

ToolsEdit

These tools are available by default in toolbox.

Icon Name Shortcut Description
Selection tools
  Rectangle R Select square or rectangular regions (axis-aligned).
  Ellipse E Select circular or horizontal / vertical elliptic regions. Notice that there's no ellipse drawing tool as such, only selecting.
  Free (Lasso) F Free-form selecting.
  Fuzzy (Magic Wand) U Select by colour in continuous regions.
  By Colour Shift + O Select by colour without any limit to continuous regions.
  Scissors I Create paths to select shapes.
  Foreground (none) Select a region containing foreground objects.
Brush tools
  Bucket Fill Shift + B Fills areas with a colour or pattern.
  Blend (Gradient) L Fill an area with a gradient.
  Pencil N Draw exact pixel-edged lines; that is, not anti-aliased.
  Paintbrush P Paints soft- or fuzzy-edged lines; that is, the pixels are anti-aliased and/or feathered.
  Eraser Shift + E Erase pixels from a layer.
  Airbrush A Paint tool with a softer pressure.
  Ink K Paint anti-aliased with a simulation of a nib.
  Clone C Copy pixels from one part of an image to another.
  Heal H Heal image irregularities.
  Perspective Clone (none) Clone from an image source after applying perspective transformation.
  Convolve (Blur/Sharpen) Shift + U Blur or sharpen an image.
  Smudge S Mix adjacent pixels; with a direction.
  Dodge/Burn Shift + D Lighten or darken an image's shadows, mid tones or highlights.
Transform tools
  Move M Move selections and layers.
  Align Q Align or arrange layers and/or other objects.
  Crop Shift + C Crop or clip all the image.
  Rotate Shift + R Rotate the active layer, selection or path.
  Scale Shift + T Scale the active layer, selection or path.
  Shear Shift + S Tilt part of the image to some direction.
  Perspective Shift + P Imitate 3-dimensional shift of an image.
  Flip Shift + F Flip selections and layers.
Other tools
  Path B Allows selecting and modifying paths.
  Colour Picker O Select the colour from anywhere in open images for further drawing.
  Magnify (Zoom) Z Alter the zoom level in the program.
  Measure Shift + M Shows distances and angles.
  Text T Place text layers into your image.

There are also some other tools, hidden by default. These tools are accessed from the "Tools" menu, or by showing them in toolbox.

Icon Name Shortcut Description
Colour tools
  Colour Balance (none) Modifies the colour balance of current selection or layer.
  Hue-Saturation (none) Adjusts hue, saturation and lightness.
  Colourize (none) Renders into a grey scale seen through coloured glass.
  Brightness-Contrast (none) Adjusts brightness and contrast. This brightness is alike to the Color/Hue/Saturation's Lightness, but from other algorithmic point of view.
  Threshold (none) Transforms the current layer or selection into black and white.
  Levels (none) Changes the intensity range of the active layer or selection in every channel.
  Curves (none) Changes the colour, brightness, contrast or transparency by means of diagrams.
  Posterize (none) Reduces the number of colours.
  Desaturate (none) Converts all colour to shades of grey.
Other tools
  GEGL operation (none) Executes a GEGL operation.

Tool optionsEdit

By default, activating any tool will have the effect of showing its options under the toolbox. Each tool has its own set of settings and any changes to them are kept through the current session. There are also four buttons under any options.

  •   Save options to... - save options of the current tool
  •   Restore options from... - restore options from saved file
  •   Delete saved options... - delete saved options
  •   Reset to default values - reset them to standard.

You can hide them by clicking on the arrow next to the tool name and deselecting Show Button Bar. You can also access these from the same menu under Tool Options Menu.

Colour, Indicator and Active Image areaEdit

 
Colour, Indicator and Active Image areas respectively.

Below the toolbox can be placed these three areas. This is set in "Edit > Preferences > Toolbox" and any of the three can be placed there.

Colour areaEdit

Shows current foreground and background colour. Clicking on either will bring the colour editor dialogue.

Clicking on the symbol in the lower left corner resets the colour to their defaults. The D key has the same effect.

Clicking on the symbol in the upper right corner swaps the foreground and background colours. The X key has the same effect.

Indicator areaEdit

Shows currently selected brush, pattern or gradient. Clicking on any of these allows to change it.

Active Image areaEdit

Displays a thumbnail of the active image. Clicking on it will bring the Images dialogue up, allowing you to select an image.


Introduction · Gradient

Introduction · GIMP · Gradient