Kdenlive/UsingKdenlive

Quickstart < Up > Command Reference


Chapter 3. Using KdenliveEdit

The Project ListEdit

The project list shows all of the clips that are available for this project.

You can see the number of times that a particular clip is in use. This includes all usage of the clip - for instance, if a clip is being displayed in the clip monitor, then that counts as one usage for the clip.

Adding clips to the projectEdit

If you drag a clip onto the timeline that is not in the project (for instance, if you drag a dv straight from konqueror to Kdenlive), then it will be automatically added to the project for you.

You can add clips to the projectlist yourself. Either use the project list context menu (right click on the window), or the Project menu on the menu bar. Select 'Add Clips' to bring up a file dialog in which you can select the clip you wish to add to this project. As long as the clips are valid, they will appear in the project list.

Deleting clips via the project listEdit

You can delete clips from your project by selecting 'Delete Clip' via the clip context menu (right click) or from the Project menu. When you delete a clip from the project list this will also remove any clips on the timeline that are using it.


Examining Clip Properties

Clip PropertiesEdit

Clean Project - removing unused clipsEdit

Use clean project to remove any clips from your project that are currently unused. This is great if your project list has become cluttered and you want to get a concise view of which clips exist. Cleaning a project will not alter your final edit in any way - the only clips that are removed are those that are no longer in use anywhere.

TransitionsEdit

Transitions are probably one of the most interesting features of non-linear video edition. They are used between two clips and they allow a soft, or a sophisticated way of passing from one scene to the other. This is a contrast with the "hard" or "dry" cut between scenes -- which, prior to the computer adoption, were very hard to make or required special equipment.

For using a transition effect in Kdenlive, you must place the two clips you want to join in different video tracks, in such a way that they "overlap" each other a little bit --- exactly in the points you want to place the transition. Then, right-click the mouse over the first clip (the "outgoing" one), then select Add transition in the context menu, and point the mouse towards the arrow for seeing the transition types available. Then you will see a yellow rectangle placed between the video tracks, representing the transition. For having a live preview of how the transition will look like, simply drag the timeline cursor from left to right over the transition area.

You can modify the transition effect, or the way it works, by left-clicking the mouse twice over this yellow rectangle. This will turn it into red and cause the "Transition" tab in the top-left panel to pop and show the properties you can set for the currently selected transition effect --- and, if you want, you can choose another type of transition, clicking at the icons at the left of this panel. We will call this operation as "entering in edit mode" for the transition.

At the time of version 0.4, Kdenlive provides four major kinds of transitions, which are expected to be expanded and more stable in version 0.5.

CrossfadeEdit

This is the most known and used transition effect --- the scenes are softly blended, the second scene becoming bolder until the first scene is completely over. This effect can also be used for the widely known fade-in/fade-out effect.

For creating the fade in/out, you can create a color clip with any desired color and use it as the first or second scene of the transition. If you simply want to use the default "fade to/from black", you can simply enter in edit mode and, at the top-left panel, click in the combobox Perform transition with: and choose "Background track (black)".

PushEdit

This transition does not blend the clips --- instead, the "outgoing" clip is "pushed out" the screen by the incoming clip.

In the edit mode for the Push transition, you must use the Start and End radiobuttons to define, respectively, where the first scene will be "positioned" in the screen during the transition --- in other words, you set the push direction. For that, just click in the rectangles of the 3x3 matrix shown. Usually you will click in the central rectangle for "Start"; you will certainly see no transition effect if you choose another start position.

The Transparency control allows you to set, well, transparency to the clip which is going out the screen. It is applied also according to the "Start" and "End" buttons. You will normally want the outgoing clip to vanish during the movement, so you will set 0 or a low value for transparency at "Start", and a higher value at "End".

Anyway, you might want the second clip to "come into the screen" --- so you can use the "Invert direction" checkbutton, and use accordingly inverted values and directions for "Start" and "End". Play around with the options until you get the desired effect.

PIPEdit

PIP stands for Picture in picture, and this transition effect causes the impression that the second clip is growing from a point, or the first clip is shrinking to a certain point.

WipeEdit

The Effect ListEdit

The effect list contains different audio and video effects. An effect can modify the video or the sound clip, like change the color balance of a video clip, or add extra gain to the sound clip.

Kdenlive audio effectsEdit

These audio effects are available in Kdenlive 0.4:

  • Mute(MLT effect) hides audio from a clip
  • Volume(MLT effect) adjust clip audio volume with keyframes

Ladspa audio effects will only be available if you have the required dependencies installed:

  • Ladspa (ladspa-sdk)
  • libJack (libjack-dev)
  • Ladspa plugins (swh-plugins)

Kdenlive video effectsEdit

These video effects are available in Kdenlive 0.4:

  • Brightness
  • Charcoal
  • Gamma
  • Greyscale
  • Invert
  • Mirror
  • Obscure allows you to mask a portion of screen with keyframable mosaic effect.
  • Sepia
  • Speed allows you to slow down, speed up, reverse play and make stroboscope effect (*)
  • Freeze allows you to freeze the clip at, after or before a user defined frame (*)

(*) Needs latest MLT cvs development version

The Effect StackEdit

The effect stack contains the effects used for the selected track element.

The TimelineEdit

Using Virtual ClipsEdit

Virtual clips work in Kdenlive differently than in other editing software. In Kdenlive, a virtual clip is the dynamic duplicate of a section of your timeline. It means that you can apply transitions, filters and everything, they will reflect in the virtual clip. One of the use of this is when you make a movie with chapters and want the same background for your titles, you can create a virtual clip for this, and then put the virtual clip as background of your titles. Then, changing the virtual zone will update all your chapters background.

The Clip MonitorEdit

The Workspace MonitorEdit

The workspace monitor shows the video that is the result of the current timeline. It works in a similar way to the clip monitor.

Inpoints and outpoints on the workspace monitor achieve the same purpose as they do on the clip monitor. You can choose a part of the current timeline, and drag a clip of it back to the timeline. You will get a "project clip", which is a clip that contains all of the clips on the timeline in the state when you made it. It is useful for grouping together a number of clips when you have finished editing them and want to be able to treat them as a single clip.

Rendering your projectEdit

When you have finished editing, you can render your project via the Render->Export Timeline menu. This brings up a dialog, which allows you to choose your export format, export options, and filename to save as.

Loading and saving your projectEdit

Load your project via the File->open menu. Save your project via the File->save-as menu.

Setup the rendererEdit

With this dialogbox, you can configure all parameters for the renderer program.