How to create gaming video/Creating a thumbnail using GIMP

Creating a video thumbnail using GIMPEdit

GIMP (GNU Image Manipulation Program is an image editor with much of the functionality of expensive photo editing suites such as Photoshop, but it's free. With all the functionality it can be daunting for a new user, so out aim here is to discuss only what you need to know to create a serviceable thumbnail to attach to a video you're going to upload.

Basic conceptsEdit

ToolsEdit

The functionality of GIMP is organized into Tools. For example there is a Move tool to move things around, a Paintbrush tool to draw directly on a picture, a Scale to grow or reduce the size of an image, and a Text tool to add text to an image. Depending of the type of editing you'll be doing, you'll find some tools more useful than others. You can then concentrate your efforts on learning those specific tools instead of the entire program.

LayersEdit

In GIMP, an image is organized as a series of Layers. Think of these a stack of transparencies laid on top of each other. Each layer has something drawn on it, for example text. But it also has transparent areas which allow whatever is underneath that layer to be seen.

As an example, a simple GIMP image might consist of a landscape in the bottom or background layer, and text in a layer above it. The text isn't drawn directly on the background, so it can be changed easily without having to reconstruct the background that makes layers such a useful feature.

Creating a prototype thumbnailEdit

Let's go through the process of creating your first thumbnail. Once you have that, you can re-use pieces of it to save time when making new thumbnails. First create a blank image of the size recommended by the service which will host your video. For example YouTube recommends a thumbnail size of 1280x720. But keep in mind that most viewers will not see the image at this resolution but much smaller, so you'll want to make sure that the important features are visible even if the image is shrunk to the size of a postage stamp. Just Select File→New from the main menu, then fill in a width of 1280 and a width of 720, leaving the other options at their default values, and press OK.

The image which is created has a single layer of white for a background. You'll probably want to use something a bit more exciting for a background though. We recommend that you save a few frames from your video while you're in the video editor. First, locate the Layers dockable tab; by default it's located in the lower right part of the screen. Because of all the tools and tabs included in the program, most tabs have subtabs, so if you don't see Layers then it may mean that another subtab is active, so look for the layers icon which is three rectangles stacked on top of each other. If the icon still isn't there for some reason, you can open it by selecting Windows→Dockable Dialogs from the main menu. In this case the shortcut Ctrl-L will open the subtab as well. You undock subtabs and move them to other tabs by dragging the icon.

Once you've located the Layers tab, there should be a single layer present, plain white and labelled "background". If you're going to get your background from somewhere else then delete this; look for the row of buttons at the bottom of the tab and press the X-button. You can also right-click and press "Delete Layer" from the option list. With no background, the image is totally transparent, which is shown as a checkerboard pattern in GIMP.

To add your frames from the game to the image, select File→Open as Layers... from the main menu, and select saved images. There is no harm in selecting all of them if you've saved more than one. The images will typically be bigger than the size of the image, but that's good since it gives you a chance to frame the image. Make sure the Move tool is active; this appears as a plus sign shaped icon in the tool selection area in upper left part of the seen, or can press M. There is a Tool Options tab which controls the currently selected tool, and you sure make sure that this shows "Layer" as what is being moved, and "Move the active layer" is selected. Now you can move the layer around within the image using the mouse. You can move it so extraneous text and other distractions are hidden outside the image, and something you want to focus on is near the center. It's a good idea to have some relatively plain areas visible since that will be a good place to place text. You can also scale the image if necessary, but we won't cover that right now.

Now that you have a background, it's a good idea to add some text. Activate the Text tool by click the A-icon in the upper left corner, or by pressing T. The Tool Options tab is more complex this time, and you can set things like font, font size, color, and other options which are best left at their default values for now. Remember that most people will see the image at a much smaller scale than youre seeing it now, so the text should be very large to be readable. We suggest a text font size of 1/8 the image height, so in our example 160 pixels. The only requirement for font is that should be readable, but you can try different styles to match the mood of the game. For color you'll want something that contrasts well with the background, so a dark color of the background is light and vice versa. For text it's more important to contrast brightness than color. The brightness of a color is determined for the most part by the green component, so rely mainly on the difference in the green component as a measure of readability. The largest text should be reserved for the name of the game, but you can also add additional text for additional information, an episode number, a very short episode title, etc. We suggest simple black or white as the color and a slightly smaller font, say 120 pixels.

When you have the text characteristics selected, just click somewhere on the image to create the text. It doesn't matter much where at this point since you can easily move the text around. You'll see a smaller version of the tool options, but just start typing to create text. When you're done, click on the image again or one a layer in the Layers tab to stop. Every time you add text, GIMP create a separate layer for it. Can can move the layers around easily by switching back to the move tools, and dragging them with the mouse as with the background image. You can also experiment with the layers themselves; click on the eye next to the layer name to turn a layer invisible, or raise and lower layers over others using the chevron buttons at the bottom of the Layers tab.

You should have a reasonable looking thumbnail image at this point. There are many more features of GIMP to explore, and the goal here is not to teach you to be graphic designer, so we refer you to the numerous instructional videos available for learning GIMP for more details. For now we just want to save the image.

It's important to save each images in two ways. First, save the image in GIMP's native XCF format. This will not be uploaded but you should save it in case you need to go back and change something later. To do this, select File→Save as... (or just File→Save, depending on circumstances) and specify a name and location. Second, save the image in PNG format. Do this, select File→Export as... from the main menu, specify a name and location, then press Export. We recommend adding something to the file name to distinguish it from other files such as the unedited frames from the game. For example add "_edit" to the end. An Export Images options dialog pops up, but you can leave all the options at their defaults and just press Export again to create the PNG file to use a thumbnail.

Reusing the prototypeEdit

Once you have one thumbnail image safely stored as an XCF file, you don't have to start from scratch anymore. Open an existing image which already has most of the work done, the correct image size, the title text, etc. Save the image under a new name, delete and replace the background layer if that's what you want, and tweak the text as needed. Then save twice again as above to create a new thumbnail.