Blender 3D: Noob to Pro/User Preferences Windows

In this module, we'll take a closer look at the Blender Preferences window.

A screenshot of the Blender Preferences window in Blender 2.80

Accessing Blender PreferencesEdit

To open the Blender Preferences window click Edit → Preferences...

In Blender 2.79, you will find it under File → User Preferences...

Configuring Your PreferencesEdit

In order to get to modeling and rendering sooner, this tutorial will cover only a few of the many user-settable preferences.

If you ever need to restore Blender to its factory settings, click File → Defaults → Load Factory Settings

Save & Load → Auto SaveEdit

As the name suggests, Auto Save automatically saves the current .blend after a specified period of time. The settings are:

  • Auto Save Temporary Files: This enables/disables the auto save feature.
  • Timer (mins) slider: This specifies the time in minutes between each auto save.

System → Number of Undo LevelsEdit

Next we'll look at the undo settings. By default, Blender remembers your last 32 actions and allows you to undo them one at a time by pressing  Ctrl + Z . If your computer has plenty of memory, you may wish to increase that number. If it has relatively little memory, you might consider decreasing it to 10 or 20. The Memory Limit slider specifies the amount of RAM (in megabytes) to use for storing the undo levels. Undo level "0" is unlimited.

Input → Numpad EmulationEdit

Blender uses numberpad keys (such as  NUM7 ) to control the 3D View and ordinary numeral keys (such as  7 ) to change layers. If you are working on a laptop or if you find the numberpad inconvenient, you can select Emulate Numpad to reassign the 3D View controls to the ordinary numeral keys.

Input → Emulate 3 Button MouseEdit

Blender makes significant use of all three buttons on a standard computer mouse. If you do not have a mouse with three buttons, enabling this setting will let you perform  MMB -related actions with  ALT + LMB 

Additional ResourcesEdit