Adobe GoLive Guide/Printable version


Adobe GoLive Guide

The current, editable version of this book is available in Wikibooks, the open-content textbooks collection, at
https://en.wikibooks.org/wiki/Adobe_GoLive_Guide

Permission is granted to copy, distribute, and/or modify this document under the terms of the Creative Commons Attribution-ShareAlike 3.0 License.


Site Creation, Structure, and Management

This chapter focuses on creating and designing a web site using Adobe GoLive

GoLive Site WizardEdit

The GoLive Site Wizard can be used to create anything from empty to template structured to imported web sites.

How it WorksEdit

The Site Wizard creates a project folder, a project file and three organizational folders to contain the elements of the site. These folders are the web-content folder, the web-data folder and the web-settings folder. While these various parts are used to organize and create the site, only the web-content folder is uploaded onto the server when publishing.

  • project file shares the name of your site and uses the .site file extension. This file is used to manage your site's makeup.
  • web-content folder contains pages, css, images and everything else needed for the published version of the site.
  • web-data folder templates, components and other reusable elements.
  • web-settings folder stores changes made in the Site Settings dialog box.

Creating a SiteEdit

The site creation process for the Mac or PC is identical and the resulting files are interchangeable across operating systems.

  1. File > New Site
  2. Select Single User
  3. Select
    • Blank Site
    • Import from Folder
    • Import from Server
    • Copy from Template
  4. Name the site (if applicable)
  5. Choose a location for the site files to reside
  6. Click Finish

Organizing a SiteEdit

Once your site has been created and populated with pages (see next chapter) you must link these pages and their elements together and to their sources to make a coherent and maintainable Web site.

Linking Pages, Objects and Their SourcesEdit

Once linked, objects will maintain their links even when their sources are moved or renamed so long as these changes occur within the site window. There are three types of links which can be applied to objects, images, etc.

  • resource links (links in the HTML which locate the objects appearing on the page)
  • navigational links (links that take a viewer from one page to another or between locations on a page)
  • external links (still technically navigational links, external links refer to any link which opens another page or email)

resource linksEdit

Do one of the following:

  • Drag the file from the site window and let GoLive create the resource link automatically
  • Manually specify the resource location:
  1. Select an object
  2. Navigate to the Inspector
  3. Change the source file

navigational linksEdit

  1. Select item to house the link
  2. If linking an image or object, click the Link tab and then the Create Link button (looks like a chain)
  3. Type the destination file in the URL text box.
  4. Use the Target menu to select a location for the link to open if you wish it to open in a frame or another window.
  5. Enter a title for the link. The title will appear when the cursor is held over the link. (This only works in some browsers.)
  6. Use the Name/ID menu to select Name & ID.
  7. Type a link name on the Name/ID line.

External linksEdit

Follow steps 1 and 2 in the navigational links section. When entering the destination file in part 3 include "http://" or "mailto:" before the destination to link to an external location. Finish as a navigational link.



Page Creation and Layout

This chapter focuses on creating and formatting web pages using Adobe GoLive

Adding and Formatting PagesEdit

Pages can be created from within GoLive or added from without. Any time you choose to add a page, image or other object to your site, do so by dragging these files into the site window. This allows you to use the file in your site without effecting the original files and allows GoLive to keep track of and maintain your files/links.

Creating a New PageEdit

While it is possible to create a page by selecting New Page (Ctrl +N) from the File menu, it is often more efficient to create each page as part of the site. There are several ways to do this.

  1. Make sure that the site window is open and the Files or Extras tab is selected.
  2. Site > New > Page
  1. Select a page from the Files tab in the site window.
  2. Edit > Duplicate
  • Drag a page onto the Files or Extras tab from the Objects palette.
  • In navigational view, follow the instructions above dragging the page next to any other page.

Formatting PagesEdit

Aspects like backgrounds, margins and keywords (used for searches) can be added before or after the creation of the rest of the page.

Page TitlesEdit

The page title appears at the top of most browsers.

  • Select the page in the site window, then open the Page tab in the inspector. Enter a new title in the Title text box.
  • Open the document window and click on the "Title" label at the top of the window. Enter a new title.

Page MarginsEdit

Page margins determine how close the contents of a Web page come to the browser window.

  1. Special > Page Properties
  2. Click Page tab.
  3. Change Margin Width and Height.
  • To quickly remove page margins right click on page. Select Document > Set Page Margins to Zero.

Window SizeEdit

You can choose to set the page layout to a certain size to help design your page to that size. The following will not actually effect the size of the browser window. Use Java Script to change the size of the browser window.

  • In document view select a size from the Layout Dimensions menu in the bottom right hand corner of the window.
  • To change the size for all document windows, follow the instructions above and then open the Settings window from the Layout and Dimensions menu. Check the box labeled Markup Document Windows.