Blender 3D: Noob to Pro/Modeling a Fox from Guide Images

This tutorial assumes that you have completed all previous tutorials.


Method 1Edit

Get the pictures of the modelEdit

Tip: The images here do not line up. Some need to be rotated and others do not match in size. They will be kept so that you can get the "real feel" for this project.

If you have a puppy and a digital camera, take three pictures of the cute little rascal and upload them. If you don't have a puppy, any object or small animal will do. Ideally, the photos will be looking straight down at the top of the puppy, a side view, and a front view. It's important that the puppy be in the same pose in all three photos! Or at least close to the same pose...we all know puppies don't stand still very long.

You could use two mirrors. One is placed next to the puppy at 45 degrees to the camera and 45 degrees to the puppy. Another is placed above the puppy, also at 45 degrees to the camera and 45 degrees to the puppy. This produces three images, one of the puppy (front \ NUM1), one of its reflection seen 90 degrees to the right (side \ right \ NUM3)), and one of its reflection seen from overhead (top \ NUM7). Take the photo from a long distance away with a zoom lens to get close to an orthographic projection.

Or how about pictures of a toy wolf taken from 6 view points?:

Using your favorite image editor, such as PhotoShop or the GIMP (see detailed GIMP instructions below: Detailed steps to align images using GIMP), down-scale the images need to a reasonable size (I made mine 512x384), and then match them to each other. To match them, draw construction lines (pulled from the rulers above and to the left) on the left view for example to pick out key features. I picked the tail, the front of the back foot, eye level, tip of the ear, and the front of the nose:

Toywolf-construction-left.jpg

I found when I picked out these features that this first image needed to be rotated slightly. That completed, I proceeded to scale, rotate and shift the other two views (top and front) until they matched fairly well as layers on top:

Toywolf-construction-top.jpg Toywolf-construction-front.jpg

Once I had the proper results I saved the resulting images, and these are the ones we will use in Blender.

The results are the files you'll need for Step Two:

Toywolf-left.jpg Toywolf-front.jpg Toywolf-top.jpg

Just right-click and save them some place where you can find them to load them into Blender for Step Two. You may notice the photos aren't perfect, but we'll use them just to show how you should deal with your real photos. When you are creating your own pictures to import, note parallax. In this example, parallax is present, and we'll attempt to compensate.

Get the Picture into BlenderEdit

Getting the image into blender is the easy part. The more difficult part will be creating the mesh, but first things first. Create a new file (File → New) to see the familiar default objects. Don't bother deleting the cube, we'll end up using it in the tutorial. Just as was done in the "Making A Pyramid" section, split the 3D Viewer into four views and assign them the following view ports. Note that the arrangement is different than that used in the previous tutorial.

NUM7 NUM3
NUM1 NUM0

Each window will show you different XYZ coordinates with the NUM0 view being what your object will look like to the camera object.

Note: More recent versions do this automatically when you press  CTRL  ALT  Q , but the default arrangement of the windows is different:

NUM7 NUM0
NUM1 NUM3


Now that the screen is set up, let's load the images. In the top left viewport (XY), click View on the viewport's header (the menu at the bottom). From the menu provided, select Background Image .... A small window will appear.

Tip: If you have a later version of Blender and the Background Image .... option is missing from the View menu, try going to View > Properties, or press  N . A new toolbar will open to the right of the viewport and by scrolling through you should see Background Images. Use the "Add images" bar and options will open up. Then check the box to display your images. (Blender 2.58 user)


Click the Use Background Image button and several more buttons will appear. Now click on the folder icon located to the right of Image:. A new full-viewport window will appear. Explore this window a bit and end up selecting the image file of the wolf from the top view. What you should get is the picture of the toy wolf from above with the default cube on top of it. Rotate your view of the cube. The picture disappeared! But don't worry - the picture is still there. Press NUM7 to realign the viewport and see the picture again.

Tip: Be sure to be in orthographic view Num 5 or else you won't see the picture.

Now load the front view of the wolf into the NUM3 (right side) viewport (YZ) as you did the top view. Repeat the procedure and load the side view of the wolf into the NUM1 viewport (XZ). As a note, each picture is specific to the viewport it was loaded into. When you switch between axes views, the picture will not change. Try this out by changing the top left viewport to NUM3 (right side) and NUM1. Return the viewport to NUM7 (top) before continuing.

Noob note: the photo from the top goes into top view, the photo from the front goes into the right view, and the photo from the right goes into front view, if you have front in front, change it now!

The pictures are now loaded into the Blender viewports. If you look at the pictures on the grid, you may notice that the front view of the wolf isn't quite center. That is okay, Blender has a way to fix it.

Move your cursor over the NUM1 (front) viewport and press Shift + SpaceBar, this expands the current viewport (NUM3/front view) to a fullscreen view, then open the Background Image window for the front view again. Notice that there are picture manipulation options available. One of these includes picture offsets. Click on right side of the 'X Offset: 0.00' to increase the offset to 0.20. The picture will be shifted over slightly so now the wolf is more centered. Press Shift + SpaceBar again to return to the four viewport view you created earlier.

Noob Note: If you made, and aligned your own photos, you will need to use a different value than '0.20' to center the head in the cube in front view.

The setup work is now done! Let's start on actually making the wolf model.

Wolftut1.png

Create a Rough ModelEdit

This is a brute force model creation using techniques discussed previously in this book. This section is meant to help you explore and become more comfortable with them. Do not try to follow the example to the tee. Your wolf and my wolf will probably not look the same since you may want to add more or have less detail.

Noob Note: If you are just getting started with blender, this step may likely take several hours to complete, since you must use your own creativity to position things in 3D space, using 2D views. Just like sculpting, drawing, or oil painting, it will be extremely fustrating at first, but once you get used to the way it works, "modeling" will be much easier.


The rough fit stage requires either some planning or on-the-spot decisions. Think about where the wolf will have parts of its body flex or require parts jutting out.


The first step is to create a blocky wolf. Start out with a column of blocks using the extrude face command (select face, EKEY). Don't worry about snapping the vertices to the grid since we are working with an organic figure.

user note: I used ZKEY (wireframe view), to see better how the rough model fits out

Figure 2.3.1 Body column formation
Wolftut2.png


The next step is to split the ears and legs off of the body. Do this by subdividing the appropriate faces. Save often, and if you make a mistake, go ahead and use the undo option (CTRL ZKEY). Also, if you find yourself looking at redundant faces, combine them (FKEY).

Figure 2.3.2 Appendage formation
Wolftut3.png]

If you are having trouble with this, try mousing over the perspective window (the one you designated with NUM0) and using the MMB to rotate the view so that you are looking at the underside of the wolf. Click on the face underneath the wolf that is alongside his front legs (use the side view to check this). We are going to subdivide this face in order to grow legs off the new faces. To subdivide, press the WKEY and choose subdivide. You will see that the face has been divided into four. Take one of these faces and extrude it as many times as is necessary to make the right leg. Then do the same again for his left leg.

Noob Note: To avoid making the extruded faces share common vertices (and be connected to each other), either extrude the legs separately (as stated above) or select Individual faces in the Extrude pop-up menu. The same works for the ears.

Doing the ears is similar, except instead of working underneath you will start with the face on top of the wolf which is directly over the ears. Select this face and subdivide it once. Deselect everything using AKEY, then select one of these four faces and extrude it upwards once to make an ear. Do the same for the face alongside it to make the other ear.

Finally, extrude the tail end of the wolf one more time, so that your wolf has as many divisions as the picture above.

Refine the rough modelEdit

Let's start refining the model starting with the tail. Try putting your viewports in wireframe mode by pushing Z, it may make things much easier. Line up the vertices over the wolf in each viewport by lasso selecting multiple vertices (CTRL LMB, Drag). then move to the right location with grab (GKEY).

Figure 2.3.3 Working on the tail
Wolftut4.png


Continue onto the hind legs of the wolf. It is trickier to manipulate the legs so keep rotating a viewport to look at the model from multiple perspectives. Remember that we are working in three dimensions.

Figure 2.3.4 Working on the hind legs
Wolftut5.png


Continue working up along the wolf fitting the blocks to the pictures. If you have problems seeing the picture because the model is in the way, let's hide the model. In Edit Mode, select the entire model by AKEY or by pressing LKEY when you have the cursor over the model. Simply pressing HKEY will hide the selected items. To unhide the view, use ALT+HKEY. By hiding and unhiding the model, or parts of the model, you should be able to keep using the picture as a guide. Note: It is much easier to just switch layers by, let's say, pressing 2KEY (not the Num-Block one) to hide the entire model (thus getting a look at the picture) and 1KEY to reveal the mesh again.


Once you have the first pass done, you'll notice that the model just won't fit all three pictures correctly. This is due to parallax. The most obvious example is the side view. The four feet should be level, as they are all standing on a flat surface. Since they are not, we'll just ignore some of the aspects of each picture and continue with the model. (This is a helpful example to show what you need to consider when taking your own pictures.)

Figure 2.3.5 Completed rough fit
Wolftut6.png

Subsurf the modelEdit

Now that the rough fit is done, let's smooth out the wolf. Add a Subsurf modifier and set the Levels to 2. The wolf will now be smoothed, but we want to add some of the hard lines back into the model. This may be accomplished with creased edges.

First, turn on the view creased edges by toggling the Draw Creases button in the Mesh Tools 1 window. Enter Select Edges or Select Faces mode (CTRL TAB). Highlight the edge or face you want to crease and press SHIFT + EKEY. Use the mouse and pull away from the center until the Crease value is close to what you want. A value of +1.000 will give you the sharpest look and is useful for places such as the bottoms of the paws. When an edge has been creased, the edge will be highlighted in yellow (positive crease) or black (negative crease). These highlights are shown due to the 'Draw Creases' button being turned on.

In this example, I creased edges along the paws, tail, ears, and nose to give them some sharpness.

Figure 2.4.1 Creased edges
Wolftut7.png


The last step is to refit the model to the pictures. You may have noticed that when the model was smoothed, the result didn't quite fit to the pictures. Now is a great time to tweak the vertices to fit to the pictures or add to/modify the model.

N00b note: if you see a weird edge on the body after smoothing, check the face normals (F9 > Mesh Tools More > Draw Normals; and then W > Flip Normals on the culprit faces).

And here is my basic wolf based on three pictures!

Figure 2.4.2 Final toy wolf model
Wolftut8.png

But where's the FOX?Edit

Somehow the fox from the title of this page turned into that beautiful wolf. Now the wolf is a magnificent animal but I really like the fox. So here is a quickie rendering of a fox, using techniques of this tutorial and some of the material techniques from a previous tutorial. MercedMike (discusscontribs) 15:00, 28 February 2014 (UTC)

Foxy

Method 2 (using mirroring)Edit

In this alternative method we will do half a wolf and then mirror it to create a complete wolf. You should start out by creating a silhouette of the wolf body in the side view, and then in front view start to shape the wolf head, tail and legs...

Noob Note: If you are attempting this method, it is best to avoid using triangles in rounded areas of a Mesh, because they tend to cause artifacts in your model (artifacts are protruding edges or other things that don't look realistic). Using quads is a much better alternative. Triangles should only be used on flat areas of your mesh if they cannot be avoided.

Wolf building side.jpg Wolf building front.jpg

Here is what you should end up with Wolf finished.jpg

Using mirroring with method 1Edit

You can also use mirroring with the first method (the one with cube extrusions).

This can speed up your work as you don't have to do the same changes on each side of the fox - just once.

To start the mirroring:

  • Go to Editing (F9)
  • In the Modifiers panel, add a Mirror
  • Check only the Y button

When modeling:

  • You may want to adjust the Merge Limit value (e.g. 0.14): this means vertices too close to each others (after the mirroring) will be merged, thus avoiding artifacts along the mirror's axis.
  • Remove the faces along the mirror's axis, otherwise Subsurf will be confused by the faces inside the body of the mirrored fox. Keep all the faces for the legs though.
  • To move the legs differently on each side: when you're done modeling the rest of the fox, apply the Mirror modifier, and then work on each leg independently.

Detailed steps to align images using GIMPEdit

From this point forward there are multiple ways to do exactly the same thing, however for simplicity's sake and so that I can be more detailed I will be using one method (the one which I use) and be using GIMP.

I found it best to size all the photos to a known width, with an easy to find center. (Mine happened to be 850x638 pixels, I don’t recommend that but you can choose any size you want really, as long as all of them are the same size). Then drag the construction lines to form a crosshair in the middle of the photo. To do this, click on the top ruler, and drag down to the middle (Exact middle) of the photo, then click on the side ruler and drag across to the middle (Again exact middle) of the photo.

If you are having trouble finding the exact middle of the photo, move the cursor to the very bottom left of your photo and the height of your photo will be listed at the bottom left of the GIMP interface. The numbers are listed in an (x,y) format so you want the first number to say 0 and the second to be the largest you can make it by dragging your cursor. The second number is the height, and half of that is the middle of your photo. You can do the same with the top ruler to find the vertical middle of your photo. Only this time the co-ordinates at the bottom left of the GIMP interface should list the second number (y) as 0, and the first number should be as large as you can make it by moving your cursor (to the upper right of the photo).Once you have your width again half of that will be the middle of your photo.

Then using construction lines put one at the top of your object, and the bottom of your object. Find the "height" of your object by the distance between them. Remove the construction lines from the top and the bottom, and place a new construction line above the horizontal center line by the half of the "height"(of your object). Now place a construction line on both sides of your object and find the “width” (distance between the new vertical lines), then remove those construction lines and place a new construction line vertically half of the "width"(of your object) to the right of the vertical center line. Now cut the object out, and drag it so that the point you used as the "top" is on the horizontal construction line that is above the middle. Then Drag the photo left or right until the right edge of the object is on the vertical construction line you put in right of the middle construction line.

Now the center of your object is at the center of your photo. This is a very important thing because when blender loads in the picture you will need this so that all of your pictures match up with each other 3d. You should repeat these steps with all 3 photos. I also don't recommend doing it in GIMP's "layered mode" as that caused more pandemonium for me. I recommend opening each photo in a new window .

Taking your pictures is the most important part, because if the pictures are not all in the same scale (object size to photo size) then your photos will not line up and you won't be able to place a dot on the same location from front view, side view, and top view.

As a recommendation I would recommend making your first model from a Lego man. That is what I did and it is very simplistic easy practice. To take my photos I took about 10 minutes to construct a photo platform for my object. It consisted of a cardboard box with two sides cut out. I covered the inside area with computer paper. I then used a 2”x4” and a ruler to make sure that the box stayed the same distance from the camera for all shots, as well as marking where the Lego man’s feet were positioned inside the box with a pencil. This will provide good pictures, providing you keep the camera at the same distance and zoom for all three photos.


Last modified on 28 February 2014, at 15:00