Last modified on 18 May 2014, at 00:52

Blender 3D: Noob to Pro/Aligning Vertices with a Guide Image

This tutorial is about using guide images to place vertices in their proper places in 3D space. The second tutorial is on how to take good reference pictures. This tutorial assumes that you have completed all previous tutorials.

This tutorial describes the use of the background image feature of Blender to assist in creating models of 3D objects. The background image provides a reference for the dimensions of the object, similar to the way the floor plan and elevation views of a house provide dimension information for the actual house. Guide images are not rendered, and may be removed after the model is completed, or they may be retained as part of the internal documentation of the model. Background images are not generally useful for other "image" purposes such as materials, textures, and actual background images in a scene, just as a floor plan is not actually visible after a house is constructed.

Background: orthographic projectionEdit

orthographic projections in six directions

orthographic projection is a technique used by architects and engineers to describe a three-dimensional object by the use of several two-dimensional images, or "projections." In architecture, the projection as seen from above is called the "plan view" or "floor plan," the projection as seen from the front is called the "front elevation," and the projection as seen from the right side is called the "right elevation." Orthographic projections are intended to assist builders in creating an actual 3D object.

A Blender user also wants to create a 3D object, in this case a model. Blender provides a way to use a set of one or more orthographic projections as a guide for object creation. Because the images are conceptually "behind" the object from the appropriate point of view, Blender calls these 2D images background images.

Each background image is located "at infinity" in an orthographic view, and there may be one image in each direction: back, front, top, bottom, left, and right. we can use one or more background images to assist our modeling effort.

For example, to model a house, we can put the "floor plan" on the bottom, and build the house above it. We put the front elevation image on the back background, and build the house in front of it. We put the right elevation image on the left background, and build the house to the right of it. The background images can be diagrams such as floor plans, or they can be photographs of an object taken from sufficiently far away to provide undistorted dimensional information.

Reasonably enough, an orthographic projection is only useful in Blender when in orthographic mode. Blender enforces this to prevent you from making mistakes: the orthographic image is only displayed in the background when you are in the orthographic view mode.

Making a Simple PyramidEdit

BlenderMakePyramid.png

First we are going to create a pyramid the easy way. Then we are going to show how to use different viewpoints and images as a guide to place vertices correctly in 3D space.

Get rid of the default cube. Press  SPACE  and select Add→Mesh→Cone. Set the number of vertices to 4, and unselect Cap End. Click OK. There’s your pyramid.


Note: Do not render this looking up from the bottom, as it will appear invisible, as the interior faces of models are ignored by most rendering engines.



Blender screenshot of ADD CONE function

In later versions (not sure when it changed)  SPACE  brings up a vastly longer menu. The way to ADD something is  SHIFT  A  then choose MESH > CONE. Then press  T  to open the tool panel and in the bottom part you will find "Vertices", set to 4, and "Base Fill Type" set to NOTHING.


Save the top vertex for later stepsEdit

Enter Edit mode ( TAB ). First, unselect all the vertices by pressing  A . Next, select the bottom four vertices of the pyramid and delete them with  DEL  or  X . The only vertex left will be the vertex which makes the tip of the pyramid. This will be used later.

Using the guide imagesEdit

Now that we have the pyramid the easy way, let's learn how to use guide images as references to build models.


Window LayoutEdit

Blender3d view name setting location.jpg

To make things easier, open a user preferences window and in the "View & Controls" sub-menu, turn on the "View Name" option. The window names will be used for reference inside the rest of this tutorial.

Split the Main 3D view window in to 4 windows.

Reminder: to split windows, move the mouse to the border of the view, when the cursor transforms into arrow, right-click and choose "Split Area". (Explained in the guide: Noob to Pro/Blender Windowing System.)


Change the point of view in each window so that they end up like this:

NUM1 NUM7
NUM3 NUM0

And if you click on View, you can see that these windows are respectively:

Front Top
Side (Right) Camera

By knowing which view you are looking at you may find that you quickly get the idea of what you are doing and can proceed somewhat intuitively in this section on your own without following all of the step by step instructions.

Guide imagesEdit

Now, we need some images. These come from a source outside of blender. For this tutorial, we need a floor plan of our pyramid, a front elevation view, and a side elevation view. The floor plan of our pyramid is a square, and the front elevation view is a triangle, as is the side elevation. We will cheat and use the same source image for both the front and side elevation. We can make a picture of a white square and of a white triangle in the GIMP, Paint :) , or some other image editor. or we can find appropriate images somewhere.

Method 1 download and useEdit

Save the triangle with a black background

Download the black and white triangle image on the right of the screen and use that. This image is, minus the checker pattern at the border, 198 x 198. (click it once to get the larger version, right click on the larger one, and save)

Method 2 roll your ownEdit

The square and triangle relationship

Noob note Make sure that the drawing of the square is square and not just rectangular. Make the triangle the same width and height as the square. Make sure the apex of the triangle is directly above the midpoint of its baseline.

Specific instructions for PhotoshopEdit

Make a square selection of "n by n" size, remember the value of "n". Fill it with white color and save. To create a triangle of needed properties make a rectangular selection of same (n by n) size, on a new layer, click RMB on your document, choose "Transform selection" option in the pop-up menu. Once you are in "Transform selection" mode, right-click the blank image again. This time the pop-up menu would be different. Choose "Perspective" from it, and with LMB drag one of the two top vertices toward the other. Once the vertices meet (in the top-center of the image), exit the transformation mode, and fill the resulting triangular selection with white.

Save the files to a place that is easy to access. Blender only supports the TGA, PNG, and JPG image formats.

Specific instructions for GimpEdit

Turn on the grid (View->Show Grid, View->Snap to Grid), use the rectangle select with a fixed aspect ratio of 1:1 (in the tool options panel) to select a square that you can flood fill. For the triangle, use the node tool to draw a triangular path, convert to selection (Select->From Path) and fill it. Or you could just use Inkscape...

Save the files to a place that is easy to access. Blender only supports the TGA, PNG, and JPG image formats.

Background ImagesEdit

Importing Image.jpg

Load the white square (the floor plan) into the top (NUM7) window by going to the 3D view window and pressing ViewBackground image → (click on the icon of a file). Find your file and click "select image". Since you are placing the background while looking at the view from the top, the background is placed infinitely far away at the bottom of the model, which is where we want it.


-I have a more recent version of blender, and this method does not work. when I hit "view". Instead, press "View" → "View Properties." In the Properties menu that now appears check the Background Image checkbox and select an image to use by expanding the Background Images submenu and pressing "Add Image."


Blender 2.6 Background images.png

-I have Blender 2.6, and "View Properties" doesn't appear, instead, on the right there's a sidebar (Usually hidden, you can clic on the + symbol to view it or hit (NKEY)). You only have to find "background image" and tick on it, you will see below a button to choose an image, and there's also another one, called "Axis", were you can select were the image should be seen (It should say: All views).


Load the white triangle (the front elevation view) into the front (NUM1) view window: this places it infinitely far "behind" the model. Similarly, load the right elevation (coincidentally, the same triangle image in this special case) from the right side view side (right or NUM3) window, to place it infinitely far to the left.

If necessary, zoom out so that you can see the whole background image in each view.

Now you have now placed your guide images for making your pyramid.

Note: for each view, if you can not see the picture, switch to Ortho view by hitting NUM5 You won't see it in top view till you do this. Furthermore, the entire idea of using guide images is based on using the orthographic projection, because in the orthographic projection, points on the same line normal to the viewing plane appear at the same point on the view.

Side OneEdit

1st vertex.jpg

The vertex that is left will be the topmost point of the pyramid. Use the GKEY to move the vertex around. To get it in the right spot, line it up at the top most point in the front (NUM1) and side (right or NUM3) windows. If you look in the top (NUM7) window the vertex should appear to be in the center. Make sure to keep the vertex highlighted for the next step.

Note: If you deleted all of your mesh objects in Object Mode (including the remaining vertex), then you'll be stuck in Object Mode. You can however, add a new mesh object as a base, or an empty mesh via a python script (AddMeshEmpty Mesh) [Blender 2.49]. Once an empty mesh object has been created, select it (right click on it or AKEY), and then change to the Edit Mode. Now you can begin to create individual vertices with CTRL + LMB.

Note: it might be helpful at some point to zoom in and use the X,Y and Z movement restriction)


1st line.jpg

Now, we are going to place more vertices in the scene. Since we want to have the new vertices connected to the first one, we will make sure the first vertex is selected and hold down CTRL and click LMB to create a new one.

In the side (right or NUM3) window, place a vertex on the lower left edge of the triangle by holding CTRL and clicking there. This should create a line between your 2 points. If needed, use GKEY to line it up in that window and also at the lower right point in the top (NUM7) window.

Noob Note: if you wind up in the middle of square (top view) then move your new vertex around with GKEY till it's in the right place in the front, side, and top views


1st face.jpg

Next, with only one of the vertices selected, in the front (NUM1) window place a vertex on the lower left edge of the triangle using the same method. Line it up in that window and at the lower left point in the top (NUM7) window.

Now, select your 3 vertices (use AKEY) in the front (NUM1) window and press the FKEY. You should see a triangle appear.

Side TwoEdit

Press AKEY to deselect all vertices and select the vertex at the top of the pyramid again. Repeat the process from Side One to make the next side. Place a vertex in each of the other corners of the square using CTRL and LMB. Line them up in two different views with the corners of the triangle and square. Make sure only the top vertex and the two new vertices are selected and press FKEY. This will fill in a face opposite of the first face in the pyramid.

Sidetwo.jpg

Sides Three and FourEdit

To fill in the other two sides, select the top vertex and the two corner vertices on a side where there is no face yet. Again, use FKEY to fill in a face. Repeat this for the last side to have all four sides created.

BottomEdit

selecting all 4 corners

In the top (NUM7) window, select all four corners and make a face. You should have a solid pyramid! Now, select all 4 faces, hit XKEY, and choose "faces".