Last modified on 17 September 2010, at 23:55

Wings 3D/User Manual/The View Menu

54 DRAFT 1.6

� WINGS3D USER MANUAL Section 5.1 The Menus 5.1.3 The View Menu Figure 40: The View Menu. VIEW MENU – GENERAL

The View Menu contains functions that set and control how you view your work; i.e.

camera and work environment settings.

VIEW | GROUND PLANE

Toggles the ground plane visibility on/off. Each grid cell of the ground plane represents one "unit" in Wings. A unit can be whatever you want it to be.

VIEW | AXES

Toggles axes visibility on/off.

VIEW | WORKMODE (Tab) Toggles the display between work mode and smoothed mode.


VIEW | SMOOTH PREVIEW (Shift- Tab)

Sets the view mode to shaded and performs one level of smoothing on a temporary basis so that you can see what your model will look like after smoothing. You cannot model in this mode.

VIEW | WIREFRAME

Sets the display mode to wireframe. If you want to extrude a face into the model, set your model to wireframe mode first and you will be able to see how far into the model you are going.

VIEW | SHADE

Sets the display mode to solid flat shading. Toggles between smooth shaded view and solid view on your model. In smooth shaded view the materials being used become visible. This is sometimes referred to as a Wings render.

VIEW | TOGGLE WIREFRAMED/SHADED (W) Toggles between wireframe and shaded

views of the model. This is a handy toggle to use in conjunction with the Tab key. Tab will show you a temporarily smooth-shaded version of your model which you can then overlay with the wireframe by hitting the W key. This wire on smoothed view can be helpful to see how edges affect the overall form of the subject while modeling.

DRAFT 1.6 55

� Section 5.1 The Menus WINGS3D USER MANUAL VIEW | SHOW SAVED BB

Shows/hides the bounding box set in the Tools Menu. If set on, a dashed wireframe outline shows the extent of the box. Wings can save a single vertex or single edge as a bounding box. Bounding Boxes can be very useful for proportionally scaling and moving a large imported object to a desired volume and position, and can also be used as reference points with vector, magnet, and “snap-to” operations.

VIEW | SHOW EDGES

In flat shaded mode, toggles the edges on/off. This can be useful for very large models, as some otherwise fast graphics cards display edges slowly.

VIEW | SHOW NORMALS

A toggle that shows/hides the normals of every face, edge or vertex (depending on which selection mode you are in) of the model, as a short thick blue line. Handy for planning how things will be moved, as a visual aid if rotating faces around an edge, and to see the normals on an imported model which may have some or all of the normals inverted.

VIEW | SHOW WIREFRAME BACKFACES

Lets you see the wireframe from both front and back in wireframe mode. This can be very useful when trying to position edges to match up on the inside and outside of a wall, for example, prior to using Bridge to cut in a window.


VIEW | RESET VIEW (R) Resets the camera to default location and zoom. Great if you get lost.


VIEW | AIM (A) Points camera directly at selected objects, faces, edges or vertices. Then when you pan and zoom in on the selected the item, it will stay centered in the work space. If there is no selection, the aim point will be reset to the origin (0, 0, 0). This is very handy when doing detailed work and for doing high aspect ratio stuff, such as a giraffe. When working on the head, select a face on the head and Aim. Then all camera movement will be centered on the head. Then when working on the feet select a face there and Aim there, and the point of focus will be on the foot.

VIEW | FRAME (Shift+A) View | Frame works similarly to Aim except that it adjusts the distance to the selection so that the selection will be visible in the Wings window. If there is no selection, the distance will be chosen so that all objects will be visible.

VIEW | ORTHOGRAPHIC VIEW (O) Toggles orthographic/perspective views on/off. Orthographic views are the same as those traditionally used for engineering or technical drawing purposes – i.e. front, side and plan views. Since there is essentially no single point of view (as in perspective) all lines and faces are seen in their true lengths and shapes - provided they lie on a plane that is at right angles to the viewing direction. This can offer an advantage when moving or editing geometry that, for example 'bulges out' towards the viewer. The use of Orthographic View is well married with the use of Move | Free, allowing you to freely move selected items while automatically constraining such movement to only two directions at a time.

VIEW | SCENE LIGHTS

Turns on any lights you may have added to the scene via the Lights primitive.

VIEW | ONE/TWO LIGHTS

Toggles one or two standard lights on in the scene. To avoid confusion consider this menu item as a request. That is, if the menu reads One Light, then two lights are currently on, and vice versa. Note that Scene lights negate the One Light/Two Light option.

VIEW | SHOW COLORS

Vertex colors can be imported on pre-existing models (such as from Nendo®). To see the vertex colors use this option.

56 DRAFT 1.6

� WINGS3D USER MANUAL Section 5.1 The Menus VIEW | SHOW MATERIALS

Materials can be created and assigned in Wings per face with the Face | Set Material command. They can also be present on models you have imported. To show materials use this option.

VIEW | SHOW TEXTURES

Models with pre-existing textures can be imported into Wings. The textures are retained after import and can be seen via this option.

VIEW | VIEW ALONG (X, Y, Z, Shift-X, Shift-Y, Shift-Z)

+X X

+Y Y

+Z Z

-X Shift+X

-Y Shift+Y

-Z Shift+Z

Sets the camera to view along the selected axis. It is recommended that you look at your model from various angles as you go, to get a good feel for how it is developing. Using the X, Y, Z (etc.) hot keys is a very quick and easy way to do this. It is also very handy to view along a major axis while scaling, as you can scale two vertices along a cross axis to spread them apart or move them towards each other. Useful in conjunction with orthographic mode for certain tasks where precise movement / alignment is required.

VIEW | ALIGN TO SELECTION

Turns the camera to point in same direction as selected elements. Wings then orientates the model such that you are viewing along the selected element's normal. This can be very useful if a single (flat) face is selected and Align to Selection is used. The face is then seen in its true shape, since the viewer is looking at it from a right angle. Selecting geometry forming that face (edges or vertices) and using Move -> Free (for example) allows movement on the same plane as the face. This keeps the face flat, which is required for clean geometry.

This is also useful in situations where you want to maintain a reference face, so that other geometry not linked to that reference

face can easily be moved on planes parallel to the reference face. To accomplish further editing of this 'external' geometry, select the reference face, use Align To Selection, and the model re-aligns to the correct position. For example, Align To Selection can be used on a flat face, then an edge can be Cut by 2 to create a new vertex. It is then possible to 'slide' the new vertex along the edge to a new position. The edge can either be kept straight via vector moves (discussed later) or 'distorted' by moving the vertex accordingly to form a new apex. In either case, by first using Align To Selection, the face will remain flat. Similar operations can be preformed via other methods as well, such as the Slide plug-in which will be discussed later.

VIEW | AUTO ROTATE (U) This will fly your camera around the model, so that it appears to rotate. The angle and speed of rotation can be set via the Edit | Preferences menu. Rotating gives you a good overall view of the model, and can be used in conjunction with screen capture software to create an AVI to show off your model. Left click to stop the rotation. You can change the aspect of the camera with the middle mouse button during rotation and the rotation will continue.

Quick Tip: View Orthographic in Wireframe Mode.

Sometimes it is not all that obvious what the difference between Orthographic and Perspective views do for you. To see this graphically, create a cube and hit the X key to look at it straight on. Then hit the O key a couple of times. It does not seem to do much other than change sizes, right? Now hit the W key to put the cube into Wireframe Mode and repeat the exercise. You can definitely see the effects of perspective now, even when looking dead on. Now use the marquee select function (drag a box) to select the top left vertex of the cube while still in perspective view. You get one vertex selected. Clear the selection and go into Orthographic View. Select the top left vertex via marquee drag. Rotate the camera a little and you will see that you got both the front and back vertices because you were in Orthographic view. This can be very useful

DRAFT 1.6 57

� Section 5.1 The Menus WINGS3D USER MANUAL when you are working on a complex but thumb, as an example, you can go into symmetrical, or nearly symmetrical model. Orthographic view and use a marquee select To get the vertices of the left and right to get both sets at once.


Image by Mentat7 (www.sargentgfx.com) Rendered in Cinema4D