Wings 3D/User Manual/The Help Menu

DRAFT 1.6 67

� Section 5.1 The Menus WINGS3D USER MANUAL 5.1.7 The Help Menu Figure 44. The Help Menu. Help Menu – General

The Help Menu contains some general information on selected topics. They are pretty self explanatory, and new users would be advised to read through them. They are brief, so it won't take very long.

HELP | GETTING STARTED

Basics on program navigation.

HELP | USING A MOUSE WITH ONE OR TWO BUTTONS

Explains how to tell Wings what type of mouse you are using.

HELP | FRENCH AND GERMAN KEYBOARDS

Explains how keyboard mapping differ for French and German keyboards.

HELP | LIGHT BASICS

Tells you how to create, manipulate, and use lights in Wings.

HELP | ASSIGNING HOTKEYS

Explains how to assign and delete hot keys in Wings3D. Figure 44. The Help Menu.

HELP | ADVANCED MENUS

Tells you how to turn on the advanced menus and why you would want to.

HELP | OPENGL INFO

Tells you some basic information about your graphics card and how it handles some of the OpenGL® properties. Could be useful information to include if you report a bug that deals with how Wings displays things on your system.

HELP | ABOUT

Displays the current revision number for Wings3D.

68 DRAFT 1.6

� WINGS3D USER MANUAL Section 5.2 6The Context Sensitive Menus 5.2 The Context Sensitive Menus The key to the Wings3D user interface is the use of context sensitive pop-up menus. These menus are accessed by right clicking in the workspace. There are a total of five context sensitive menus; the Primitives Menu, the Vertex Menu, the Edge Menu, the Face Menu and the Object Menu, not to be confused with the Objects Menu on the Main

Menu). Depending on what is selected, different menus will pop up presenting the user with operations that are applicable to the current situation only. In this way the interface is kept clean and simple, a joy to work with compared to many overly complex user interfaces found in some graphics and modeling packages.

5.2.1 The Primitives Menu Primitives Menu – General

Figure 45: The Primitives pop-up menu. To bring up the Primitives Menu, right click on the empty

workspace, or on a workspace where nothing is selected. You will be presented with a list of available primitives to add to your workspace. Left click on one of the primitives to add it. It will be added to the center of the scene as an unselected object at it's default size. You may need to turn other objects' visibility off (via the Objects Menu) in order to find the newly added object. The complete list of standard primitives is given below. Notice that some primitives have a little box icon to the right of their name. This is the Options Box for that primitive. If you click on the primitive name you will add a default primitive, whereas, if you click on the options icon you will be presented with some options (number of sections, number of slices, etc.) that you can change.

Tetrahedron – a four sided object; a triangular pyramid. Octrahedron – an eight sided object. Octotoad – A twenty-six sided object, unique to Wings. Designed by Mike (roadtoad), the host of the Wings discussion forum, and added to the Wings primitives as a tribute to the great service this board provided in the further development of Wings3D. Dodecahedron – a solid object with twelve faces. Icosahedron – a solid object with twenty faces. Cube – Plain and simple. What most models start out as. Cylinder – Click on the options button (the little box on the right) for the Sections option. A Windows dialog box will come up showing the number of sections in the cylinder (16 by default). You may change this and then click OK, or click Cancel. If you do not click on the options button, but simply click on the name Cylinder, then a default cylinder will be added (with 16 sides). Cone – Sections (16 by default). Sphere – Sections (16 by default) and Slices (8 by default). Torus – Sections (16 by default) and Slices (8 by default).

Last modified on 17 July 2008, at 21:21