Last modified on 4 November 2012, at 17:17

Kdenlive/Interface

Kdenlive has, with no doubt, one of the simplest interfaces you can find in video editing softwares. It is a typical multitrack editor, with a portion of the main window being used for showing the files used in the project, a timeline made of multiple audio and video tracks where you put those files or clips made from them; another portion of the window with a pair of video monitors to allow you to watch those files and also the contents of the timeline; plus the usual menus which you see in lots of other applications.

The Project AreaEdit

Effect ListEdit

Project TreeEdit

TransitionEdit

The Effects StackEdit

The Effects Stack shows which effects were applied to the selected clip in the Timeline. From there, you can edit the settings of an effect; and if you don´t want one of the effects to be applied, you can simply remove it from the stack.

The TimelineEdit

The TimelineEdit

Kdenlive allows visual and audio tracks to be layered separately or grouped together in the timeline: the highest video clip in the timeline obscures whatever is below it when played back in the project monitor. Audio tracks mix together.
Files can be dragged in their entirety from the project tree straight onto the time line or select portions from the Clip Monitor using Set Zone In and Set Zone Out buttons (mark in and mark out)

The MonitorsEdit

The monitors are those little rectangular black boxes which play video or audio in your project. They are divided in notebook tabs, but you probably will not have to deal with those tabs --- the appropriate monitor is automatically selected according to what you are doing at the moment.

All the monitors are equiped with playback controls --- those "Play", "Rewind", "Fast Forward", "Pause" and other buttons you have already seen in most media players. Those buttons have some "hidden" functionalities --- for example, the Rewind and Fast Forward buttons may be pressed more than once for reversing or forwarding the video/audio in different speeds.

You can use the mousewheel to move back and forward in the monitors, one frame at a time. Pressing Ctrl while using the wheel changes it to move one second at a time.

The Clip MonitorEdit

The Project MonitorEdit

This monitor shows the video that is the result of the current Timeline. It works in a similar way to the Clip Monitor.

Inpoints and outpoints on the Timeline Monitor achieve the same purpose as they do on the Clip Monitor. You can choose a part of the current timeline, and drag a clip of it back to the timeline. You will get a "project clip", which is a clip that contains all of the clips on the timeline in the state when you made it. It is useful for grouping together a number of clips when you have finished editing them and want to be able to treat them as a single clip.

The Capture MonitorEdit

This monitor shows video from a DV device connected to your computer. You can find more details on it in the Capture page.

Changing the interface layoutEdit

Kdenlive allows you to change the position of the various areas you see in the main window. Four stock combinations are provided, but you can modify them freely or create a new, unique combination.

For using the provided layouts, you can simply click on those 1, 2, 3, 4 buttons you see in the main window toolbar.

Menus and default key shortcutsEdit

WARNING - This list may be out of date at each new Kdenlive release, so don´t take it too seriously.

The File MenuEdit

  • File->New (Ctrl-n)

Creates a new document.

  • File->Open (Ctrl-o)

Open a saved project.

  • File->Open Recent

Open a recently used project.

  • File->Save (Ctrl-s)

Saves the project.

  • File->Save As...

Saves the project under a different filename.

  • File->Quit (Ctrl-q)

Quits Kdenlive

The Edit MenuEdit

  • Edit->Undo (Ctrl-z)

Undo the last edit to the timeline.

  • Edit->Redo (Ctrl-Shift-z)

Redo a previously undone edit to the timeline.

  • Edit->Cut (Ctrl-x)

Non-functional at present.

  • Edit->Copy (Ctrl-c)

Non-funtional at present.

  • Edit->Paste (Ctrl-v)

Non-functional at present

The Project MenuEdit

  • Project->Add Clips

Add clips to the project list.

  • Project->Delete Clips

Delete the selected clip from the project. This deletes all references to the clip, including those on the timeline, or those within composite clips.

  • Project->Clean Project

Remove unused clips from the project list.

  • Project->Clip Properties

Non-functional at present

The Timeline MenuEdit

  • Timeline->Move/Resize Tool (q)

Select the move/resize tool to use on the timeline. This tool lets you move and resize clips on the timeline. It is the standard operating mode of the timeline.

  • Timeline->Razor Tool (w)

Select the Razor tool to use on the timeline. This tool will cut (razor) the clip into two pieces at the time selected.

  • Timeline->Spacer Tool (e)

Select the Spacer tool to use on the timeline. This tool lets you select all clips to the right of where you click on the timeline.

  • Timeline->Snap To Frames

If checked, all operations will snap to the nearest frame.

  • Timeline->Snap To Border

If checked, moving and resizing clips will snap to nearby clip borders and the seek marker.

The Render MenuEdit

  • Render->Export Timeline

Export the timeline to a video clip. Also known as rendering down.

The Layout MenuEdit

  • Layout Menu->Load Layout 1/2/3/4 (F9/F10/F11/F12)

Loads up a previously saved screen layout.

  • Layout Menu->Save Layout 1 (Ctrl-Shift-F9/Ctrl-Shift-F10/Ctrl-Shift-F11/Ctrl-Shift-F12)

Saves the current screen layout to the respective layout slot.

The Settings MenuEdit

  • Settings->Show Toolbar

Show/hide the toolbars.

  • Settings->Show Statusbar

Show/Hide the status bar.

  • Settings->Configure Shortcuts...

Configure Kdenlive keyboard shortcuts.

  • Settings->Configure Toolbars...

Configure the toolbars.

  • Settings->Configure Kdenlive...

Configure Kdenlive

The Help MenuEdit

  • Help->Kdenlive Handbook

View the Kdenlive handbook (this document).

  • Help->What's This? (Shift-F1)

After selecting this, click on part of the gui to find out what it does.

  • Help->Report Bug...

Report a bug about Kdenlive

  • Help->About Kdenlive

See information about Kdenlive, including the license, authors and contributers.

  • Help->About KDE

See information about the KDE project.