GIMP/Colours

GIMP can understand a number of different colour formats with a varying degree of support. It supports three so called modes: RGB, grayscale, and indexed.

To change the mode of the image, choose in the menu from <Image> Image > Mode > ....

Colour ModesEdit

GIMP supports the following color modes:

  • True Colour (RGB): This has the best support in GIMP. It is made up from 3 channels of 256 tonal variants, making a total of 16.7 million colours - 256 * 256 * 256.

    Supported formats: XCF, PNG, TGA, TIFF, SGI, BMP.

  • Grayscale: The grayscale mode uses one channel to display a gray image. GIMP supports grayscale well and is usable for most tools that don't specifically require colour information.

    Supported formats: XCF, PNG, TGA, TIFF, SGI.

  • Indexed: In this mode, the image consist of pixels picked from a palette of up to 256 colours.

    When you convert an image into this mode, or when you are reducing the color depth of an image, dithering options give you control over how colours are scattered. For the best quality results (especially with pictures that have gradual tonal variance) use Floyd-Steinberg dithering: it will give a grainy texture to the picture, but reduce visible banding between different colours. On the other hand, reduced or no dithering will result in smaller files when saved as GIF or PNG (or BMP with the Run-Length Encoded option set).

    Supported formats: XCF, PNG, GIF, BMP.

  • Monochrome: Two colours, often black and white. GIMP sees this as an indexed image with only 2 colours.

    Supported formats: XCF, PNG, GIF, BMP.

Menu items for color modes:

  • Image > Mode > RGB
  • Image > Mode > Grayscale
  • Image > Mode > Indexed

Alpha ChannelEdit

Regardless of the mode, images can have an optional alpha channel for transparency. An image with an alpha channel can have transparent and semitransparent pixels, the degree of transparency of each pixel ranging from 0 to 255. Using transparency enabled by alpha channel, you can create a picture by stacking several layers on top of each other, save images for the web, or create images for 3D graphics that have holes or semi-opaque areas.

Formats that fully support alpha channel: XCF, PNG, TIFF, TGA, SGI. Formats that only support alpha channel as fully opaque or fully transparent: GIF, XPM.

Only Internet Explorer versions later than version 7 support transparency. Internet Explorer 6 and earlier do not.

Menu items for alpha channel:

  • Layer > Transparency > Add Alpha Channel
  • Layer > Transparency > Remove Alpha Channel
  • Layer > Transparency > Add to Selection

Colour Filter/ToolsEdit

Image, Mode, Decompose will split a colour image into a set of greyscale images, based on various colour models. Image, Mode, Compose does the opposite, combining greyscale images into colour ones. Striking effects may be obtained by recombining channels in a different model or order than they were decomposed in.

A number of colour adjustments can be found under Image, Colours, and colour effects under Image, Filters, Colours


BibliographyEdit

Editing · Saving

Editing · GIMP · Saving
Last modified on 10 April 2013, at 11:32