Blender 3D: Noob to Pro/Die Easy 2

The previous Die Easy tutorial needed so many changes to adapt to Blender 2.44 that it was easier to start from scratch. This Die Easy 2 tutorial is heavily based on Die Easy and Die Another Way, and adds improvements.

In the following tutorial, you will use:

  • polygon mesh
  • face loop cutting
  • subdivision surfaces
  • subdivision creases
  • bevel
  • set smooth
  • multiple materials
  • extrusion
  • merge vertices


Start with a beveled cubeEdit

Start with the default scene: Blender should be in Object Mode and in Top view, with the default cube selected.

  • Go to Edit Mode ( TAB ). All the vertices should still be selected. (If not, press  A  to select all).
  • Let's bevel the cube. The bevel option is in the modifiers context. Click on the modifiers icon (the little blue wrench on the side panel) and from the add modifiers choose Bevel.
    • Noob note :- for anyone using v2.56 and below, Press  W , select Bevel from the menu and click OK
  • Set the bevel to 0.1 by typing .1 and pressing  ENTER .
  • Finally, Apply the modifier to your cube before proceeding.
             (For Blender 2.63 : You should be in 'Object Mode' in order to Apply the Bevel Modifier.)
 
  • For Blender versions earlier than 2.48 : in the Recursion: 1 OK dialog, Press  ENTER  (it will revert to the black on grey) and click on the OK button. (For Blender version 2.48 and above, skip this step)
Note : The recursion levels go from 1 to 4. At 1 it seems to be crude but the cube will be subdivided later, so a higher recursion level is not required.


Bevel-done.png

Divide the facesEdit

A typical die face is made of a grid with 9 possible spot positions. The gaps between the spots usually measure half a spot (a spot radius). Using the spot radius as a unit, a die face will be conveniently divided into 10 equal parts through the length (that is, four gaps and three spots each two units long).

9 posiciones.jpg
Muescas y espacios.jpg

First divisionEdit

  • Make sure you're still in Edit Mode (else hit  TAB ), that you're in Front view ( NUM1 ), and that the whole cube is still selected.
  • To divide the faces of the cube into 10 vertical strips :

For v2.57 and above :

  • Just use the loop cut and slide option by hitting  CTRL + R  in the tool shelf to the left and scroll the mouse wheel to scale up the number of cuts to 9.

For other versions of Blender :

  • Press the  K  and choose Knife (Multicut) from the popup menu.
    • A new popup asks: Number of Cuts: 2. Change the value to 9:
      • click on the of word and type 9,
      • or drag from the input field ( LMB ) until you reach 9,
      • or use the right arrow.
    • Then click on OK.
Blender-Die Easy 2-Knife.png
  • To actually use the Multicut tool, draw one vertical cut through the cube: the knife icon traces a pink line. It doesn't have to be exactly vertical nor does it have to go through the cube center.
Front-face-9v-cuts.png
  • Finally press  ENTER  and all the faces of the cube crossing the knife will be divided into 10 vertical strips.

Note: You can have a look at all the other faces by dragging with the  MMB .

Noob Note: When you are cutting through the cube, make sure to cut the entire cube, including the beveled part of the cube. Otherwise your cube won't divide properly.

Remove extra cutsEdit

To get each spot position to be a single face rather than four contiguous faces, the second, fifth and eighth cuts must be removed.

  • Press the  A  to deselect all the vertices, switch to Edge select mode and make sure Limit selection to visible is off (in Blender 2.46 and above this button is called Occlude background geometry).
Select-edge-mode.png
The button is disabled (off)
Second-cut-selected.png
  • Select an edge from the second cut, and choose Select → Edge Loop from the viewport menu. This automatically selects all the edges around the cube (in a loop).

Note: You can alternatively press the  ALT  key while selecting an edge from the second cut to select all the eges belonging to this cut around the cube.

For Linux users: If pressing the  ALT  key while selecting an edge from the chosen cut brings up a Linux menu, try hitting  Shift + ALT  instead.


Second-cut-removed.png
  • Press the  X  and select Edge Loop from the popup menu. The cube will look like this:
  • Deselect all ( A ) and repeat the same actions to remove the fifth and eighth cuts:
Fifth-cut-selected.png
Fifth-cut-removed.png
Eighth-cut-selected.png
Eighth-cut-removed.png

Other divisionsEdit

For the horizontal cuts use the same steps as above, but horizontally!

Noob Note: Make sure the whole cube is selected when cutting.

Front-face-9h-cuts.png
Front-face-h-cuts-finished.png
  • Now, if you rotate the cube around, you will see that the front and back faces ( CTRL + NUM1  to see the back face) are divided vertically and horizontally. But the four other ones were only divided once.
  • To complete the divisions, go to the Side view ( NUM3 ), select the whole cube ( A ). Make the vertical cuts and remove the second, fifth and eighth cuts again:

All-cuts-done.png

Colouring the CubeEdit

Shading-panel-icon.png

You need to be in object mode for this step. Select the Shading group from the header in the Button Window ( F5 ).

  • edit Properties Window in ver 2.64

Change the name of the material (which for example defines colours) currently linked to the cube: in the Links and Pipeline panel, under the title "Link to Object", click on "Material" in the "MA:Material" box. "Material" will now be highlighted: delete it and type "DieWhite" instead, then press  ENTER .

Material-ramps-panel.png

Now choose a color: go to the next panel (the one with two tabs, Material and Ramps), and make sure the Material tab is selected.

Manual-Part-I-Interface-ColorSelector-Dialog.png

In the second group of buttons, click on the colour bar which is on the left of the Col button: it opens the colour selector.

Select the colour you want in the rainbow bar (bottom left of the popup), move the tiny circle in the colour window above it to adjust the shade. When done, press  ENTER .

Note: you can choose any colour. In this tutorial we selected the white colour by clicking on the corresponding box available from the sixteen predefined ones (the two vertical rows in the middle).

Adding the spotsEdit

Face-select-mode.png

Go to the Front view ( NUM1 ) and set Face select mode. Also make sure that Limit selection to visible is enabled (in Blender 2.46 and above this button is called Occlude background geometry).

We will create two different kinds of spots.

First methodEdit

Alt-m-one-spot.png

This one's from the Die Another Way tutorial.

We'll make the number five on the current face. Deselect all ( A ) and select a first spot (the one in the top left corner).

Extrude the face by hitting  E  and then  ESC  (do not click after hitting  E ).

Collapse this face by using  ALT + M  and choosing At Center from the popup menu. This merges the four corners of the extruded face into its centre. Click on the message saying Removed 3 Vertices.

Alt-m-five-spots.png

Repeat the same keystroke sequence on the four other spots:  E ,  ESC ,  ALT + M ,  ENTER ,  ENTER .

Now choose the Vertex select mode and select five vertices, one at each spot center ( RMB  for the first one,  SHIFT + RMB  for the subsequent ones). Then push the selection inwards using the  G  and constraining the move to the Y axis ( Y ). Move by 0.17 units to get the same die as shown in the picture below.

Alt-m-five-spots-grabbed.png

Second methodEdit

This method was suggested by Natume in the Die Easy tutorial and modified by another user.

Deselect all ( A ) and select the faces you want to create spots on ( RMB  for the first one,  SHIFT + RMB  for subsequent ones).

Press the  E  to extrude them, if you selected more than one face a popup menu will give you two options: press  ENTER  to select Region (the choice doesn't matter), and then press  ESC . Do not click after hitting  E .

Divide the selected faces into triangles with  CTRL + T  (or  SPACE  → Edit → Faces → Convert to Triangles). [Noob note: In versions 2.63+, in the subdivide choices menu that pops up at the bottom of the tools menu, you must make sure that the check box for Quad/Tri Mode is checked or only the diagonal line will be divided and no triangles are created]

Face-converted-to-triangles.png

Deselect all ( A ) and change to Edge select mode. Select all the diagonal edges resulting from the above divisions, and subdivide them:  W  (or  SPACE  → Edit → Edges → Subdivide).

Face-spots-subdivided.png

Now deselect all ( A ), go into Vertex select mode and select all five vertices of each spot face (for example, use circle select with  B ,  B , and adjust the size of the circle with  SCROLL , then click  LMB  to select; click  RMB  when the selection is complete). [Noob note: In versions 2.63+, C activates the Circle Select mode, B activates the Box Select mode]

Push the faces inward by 0.17 units ( G ,  Y ).

Alt-m-five-spots-grabbed.png

Third methodEdit

In the prior two methods you create indentations in the faces that are triangle ( mountain peak ) shaped, if you would prefer them to be square shaped ( or flat ) then simply select the faces (using face select mode) that will be used as spots and extrude them inward by the prescribed number of units (either .17 or -.17 depending on the side).


Five-spots-extruded.png

The other die facesEdit

Now repeat the method to the other faces. Remember that adding two opposite face values (of the die) yields 7.

If you started with the Front view ( NUM1 ) and set 5 spots, the Back view ( CTRL + NUM1 ) will have 2 spots (the extrusion length will be -0.17 instead of 0.17).

If you then go to Side view ( NUM3 ) — the righthand side — and put 6 spots there (extrusion -0.17 along the X axis,  X ), the lefthand side ( CTRL + NUM3 ) will have 1 (extrusion 0.17).

If you put 4 on the top (Top view  NUM7 , extrusion -0.17 along the Z axis,  Z ) then the bottom ( CTRL + NUM7 ) will have 3 (extrusion 0.17).

When all the spots have been created, the cube should look like this — the top lefthand corner is nearest, using the first method (named Alt-M)

Alt-m-all-spots-done.png

using the third method (named Ctrl-T)

Ctrl-t-all-spots-done.png

Subsurfing and smoothingEdit

The Editing panel icon, Modifiers panel and Set Smooth button

Leave the Edit Mode for the Object Mode ( TAB ) and select the Editing panel in the Buttons window (or press  F9 ).

To turn on subsurfing, click on Add Modifier in the Modifiers panel (if you can't see the button, make sure the tab is selected) and select Subsurf from the popup menu.

The default value for Levels is 1 and for Render Levels is 2. For a nicer preview, change Levels from 1 to 2 by clicking once on the right arrow, and click on Set Smooth in the Links and Materials panel.

The cube will now look like this (Front view):

method 1 & method 2
method 3

Subsurface creasingEdit

On a die, the edges around the spots are usually sharp so we'll use subsurface creasing to do that.

Go back to Edit Mode ( TAB  once or twice), and Edge select mode ( CTRL + Tab   2 ) either select every spot perimeter as shown below ( RMB  for the first one,  SHIFT + RMB  for the others), or use circle select as described next

Creasing-five-spots-selected.png

Using circle selectEdit

You should be in Edit Mode, be in "Edge select mode" ( CTRL + Tab   2 ), and have occlude background geometry turned on.

 A  once or twice to be sure everything is deselected.

 B , B  to TURN ON circle select mode.

Noob note: In Blender 2.5x circle select mode can be used by pressing  C  once.

 MMW  roll (don't press) middle mouse wheel to size the circle small enough to select single edges.

 LMB  about twenty times, as there are 4 edges around each of 5 "dots", so you will have to click 20 times with the left mouse button (once on each edge) to select them all. If you select an extra unwanted edge anywhere Then you can just click the  MMB  (My wheel rolls or presses in).

 RMB  to TURN OFF circle select mode.

Creasing the edgesEdit

Now move mouse pointer crosshairs (don't press any button here) near center of drawing.

 SHIFT + E  to turn on Edge Crease mode. The bottom bar changes to a "Crease" number.

Now move mouse pointer crosshairs (don't press any button here) away from center of drawing. Watch the Crease number change as you pull out. It maxes out at 1.000.

 LMB  When you get the crease you want the left mouse button locks it in place.

 A  once, or twice, to deselect every thing.

Finished on this side. View a different side and do it all again.

Creasing-five-spots-done.png

Note: the  N  shows an information box (with the perimeter edges still selected). The last line says: Median Crease W: 1.000, if the value is less than 1.000 it means that an edge has been missed. You can update the crease values by clicking on the arrows. Click on the X in the top right corner to dismiss the dialog.
Noob Note: setting the value of the subsurf creasing affects the subsurf modifier. You will not actually see the creasing effect unless the object has the subsurf modifier active. Try adding the subsurf modifier to the object then set the creasing to one so that you can see the effect it actually has on the object.

Now crease the spots on the five other sides of the die. You should end up with:

method 1 & method 2
method 3

Colouring the spotsEdit

Creating a new materialEdit

Go to the Editing panel ( F9 ) in the Buttons Window.

The Links and Materials panel should be showing (in the right column) DieWhite and, under it, 1 Mat 1:

Links-and-materials-colour-showing.png

To add another material, click on the New button (right under 1 Mat 1). This label changes to 2 Mat 2, and DieWhite changes to DieWhite.001.

Note: if your Blender version is older than 2.44, there's an additional step. Go to the Links and Pipeline panel (Shading or  F5 ), click on the 2 button right after the MA:DieWhite input and choose Single user in the popup menu.

user request: please provide instructions for 2.45, 'Links and materials' panel has been replaced with 'Links and Pipeline' panel. 'ADD NEW' from dropdown initially containing 'MA: Material' does not increment the '1 Mat 1' fields leaving no clear way to add more than one material to an object. -- Answer from another user: You're looking at the Shading panel ( F5 ), you need to switch to the Editing panel ( F9 ), there you'll find the buttons just as described here.

Set the colour for this new material: click on the white square on the left of 2 Mat 2 (in the Editing panels) or on the left of Col (in the Shading panel). To get the same colours as in this tutorial, choose black. Press  ENTER  to confirm your choice.

In the Links and Pipeline panel (Shading or  F5 ), change the material name from DieWhite.001 to SpotBlack.

Selecting the spot facesEdit

Now go into Edit Mode, choose Face select mode and make sure Limit selection to visible is on.

Version 2.46 The "Limit Selection To Visible", is now "Occlude Background Geometry". It remains the button to the right of "Face Select"

Starting again with Front view ( NUM1 ) use circle select ( B ,  B  — use  SCROLL  to reduce the size of the circle to less than the spot size so you don't select the outside faces) to select all the inside faces of each spot.

Press  RMB  to finish, select the Back view ( CTRL + NUM1 ), use circle select again and select the spot faces there, do the same with the other four die faces.

Note: you can't change to a different face without stopping the circle select tool ( RMB ). You will have to click  RMB , change to another face, and start circle select again ( B ,  B ).

This is what you should see when you have selected all the spots:

Alt-M
Ctrl-T

The selected faces internal to the spots are more visible in the Alt-M version as the spots created in Ctrl-T are more cylindrical; the Alt-M spots look more like hemispheres.

Assigning the new material to the spotsEdit

Now that all the spot faces are selected, you can assign the SpotBlack material to them.

Go back to the Editing panels ( F9 ) and, in the Links and Materials panel make sure the material SpotBlack is selected. If it isn't, you can select it by clicking on the right arrow or the 1 on the right of 2 Mat 1, which should update to 2 Mat 2. Now click on the wide Assign button below and the spots will change to black (or the other colour you chose).

Here are the finished results:

Alt-M
Ctrl-T

AfterwordEdit

Here's an external link to a tutorial showing a completely different way to create a die:

The most efficient and easy tutorial can be viewed at:

Last modified on 8 February 2013, at 10:28