Blender 3D: Noob to Pro/3D View Windows

3D View Blender2693DViewIcon.png windows in Blender are used to visualize 3D scenes. You’ll do a lot of work in these windows, so you will need to learn your way around.

Note:

The 3D view only shows an approximation to the final appearance of the scene. The overall geometry should be correct, but don’t expect accurate rendition of materials, textures, lighting etc, since that can be very time-consuming, and the 3D view is designed to respond to your actions at interactive speeds. Plus there are additional view options (like wireframe, hiding etc) that make it easier to see what parts of the model you’re working on, that have no effect on the final render. Also you can change your viewpoint at any time (which will be essential while working on your model/scene), while the viewpoint of the render is controlled by the camera position.

 

In this module, you'll learn:

  • to recognize 10 things commonly seen in viewports
  • to tell which mode Blender is in
  • how to change viewport options and viewpoints
  • how to position the 3D cursor

You'll also learn the fundamentals of:

  • visibility layers

The Viewport and its ContentsEdit

Aside from its header, the remainder of a 3D View window is its viewport. In Blender, you use viewports any time you need an up-to-date view of the scene you're working on.

Viewports are busy places. Go on a scavenger hunt and see what you can find in a simple viewport.

  1. Launch Blender.
  2. Just so we're all looking at the same scene, load the factory settings using File → Load Factory Settings.
  3. Confirm Erase All with  LMB  (or  Enter ).
  4. If the NumLock indicator on your keyboard is unlit, press  NumLock  so that numpad hotkeys will work properly.
  • In Blender 2.67a, Load Factory Settings menu is "load default file and user preferences" so it doesn't show Erase All message.

(If you're unsure what  LMB  means, please review the Keystroke, Button, and Menu Notation module.)

You should see something like this:

Blender-2.57 viewport outline.png
Here the viewport has been outlined in red to focus your attention on it.

A Virtual Scavenger HuntEdit

Peer into the viewport at the default scene provided by the creators of Blender and find the following eight items:

In the Center

1. Blender-2.5 cube object mode.PNG a solid gray cube with orange edges.

  • This is the default cube, your first Blender object!

2. Blender 3D Manipulator screenshot.png Three big arrows, one red, one green and one blue, their tails joined to a white circle

  • This is not an object (part of your model/scene), but part of Blender’s user interface for manipulating objects. It is the manipulator, also known as the 3D transform widget.
  • The arrows represent the directions of the X, Y and Z axes of the currently-chosen transform orientation coordinate system. Initially this is the global coordinate system.
  • The circle represents the center of the selected object (namely, the cube).
  • If you don't know what a "global coordinate system" is, please review the module on Coordinate Spaces in Blender.
If you don't see the manipulator...
  • It's possible that a tool is active. Press  Esc  to cancel any tool action.
  • Another possibility is that the manipulator has been disabled:
    • Toggle it on or off with  Ctrl + Space .

3. Blender 2.49b cursor.png A red-and-white striped circle with black cross-hairs

  • This is not an object. It is the 3D Cursor, which indicates where newly-created objects will appear in the scene.
  • The cursor is similar to the insertion point in a text editor, which indicates where newly-typed text will appear in a document.
In the Lower Left Corner

4. Blender 3D mini axis screenshot.png

  • This is not an object. It is the mini axis, and its orientation matches that of the global coordinate system, with the usual conventions: red for X, green for Y and blue for Z. Think of it as a little compass, reminding you which way is left/right, front/back and up/down.

5. The notation "(1) Cube"

This is not an object. It is object info, indicating that:
  • You're viewing the first frame of an animation.
and
  • The current or most recently selected object is named "Cube".
In the Upper Left Corner

6. The notation “User Persp”

This is not an object. This is telling you something about the view being displayed by the viewport. The first word will change if you select one of the perfect views or the camera view (see below), otherwise it just says “User”, and the second word is “Persp” or “Ortho” to indicate whether this is a perspective or orthographic view.
To the Right of Center

7. Blender 2.49b lamp icon.png A black round thing that resembles a sun-symbol

This represents a lamp, a light source for the scene. (It is an object.)

8. Blender 2.49b camera icon.png A pyramidal wireframe thing

This represents a camera, a viewpoint that can be used for rendering. (It, too, is an object.) The direction it is looking is out the base of the pyramid. The solid triangle attached to one side of the base is to remind you which way is up in the image that the camera takes.
On a small display, the camera might initially lie outside of the viewport and thus be invisible. In that case, zoom out by scrolling with  MMB  until it becomes visible.
Throughout

9. A dark gray background, divided into squares by lighter lines. This is the grid floor, which you can (but don’t have to) use as a ground plane for positioning your models.

Each grid square is one blender unit (or BU) on a side. A BU can be whatever you wish: an inch, a centimetre, a mile, or a cubit. Blender lets you decide what the scale should be for your scene in the Scene tab of the Properties Panel.

10. Three mutually-perpendicular coloured lines associated with the grid floor: the red and green ones lying horizontally in the floor and the blue one running vertically. These are the global coordinate axes for orienting your scene: as usual, red is the X-axis, green the Y-axis, and blue the Z-axis.

  • In Blender 2.67a, you can't see the blue line for Z-axis here because you can see it in Front or Side view.

ModesEdit

Blender has lots of modes, that is, settings that affect its behavior, and this is especially true of 3D View windows.

Sometimes it's not obvious what modes are active. This leads to mode errors where Blender will do something you didn't expect because you thought it was in one mode and it was actually in another.

In Blender, the function performed by a hotkey or mouse button can depend on:

  • what mode the user interface is in,
  • whether the keyboard is in NumLock mode,
  • which window is active,
  • the mode the active window is in,
  • which item or items are selected,
  • whether you've initiated a hotkey sequence.

It helps to recognize the common modes and get out of them.

Object Mode vs. Edit ModeEdit

The 3D View windows are normally in Object Mode. In this mode:

    • The mouse pointer is a white arrow (on MacOS it is black).
    •  RMB  is used to select objects in the scene

If there are objects in the scene, you can get into five other modes:

  • Edit Mode: used to edit the shapes of objects
    • The mouse pointer is a thin inverse-video cross.
    •  RMB  is used to select vertices, faces or edges of the current object.
    • Press  Tab  to enter/exit this mode.
  • Sculpt Mode
    • The mouse pointer is now a thin, orange circle.
  • Vertex Paint
    • The mouse pointer is the same as in sculpt mode, a thin, orange circle.
  • Texture Paint
    • The mouse pointer is a thin white circle.
  • Weight Paint
    • The mouse pointer is again, a thin orange circle

These modes are also indicated by a menu in the 3D View header. You can use this menu to change modes.

Blender-2.5 mode menu.png

These modes are a setting shared by all 3D View windows. In other words, when you change the mode in one window, any other 3D View windows change mode also.

Viewport OptionsEdit

Note:

The options in this section only affect 3D View viewports. They do not affect renders.

 

Solid vs. WireframeEdit

By default, the 3D View window draws objects using the Solid drawtype, in which surfaces are opaque. To toggle between Solid and Wireframe drawtype (edges only, no faces) for a particular viewport:

  1. Activate the 3D View window.
  2. Press  Z .

Alternatively, you can choose these and other drawtypes from the "Draw type" menu in the 3D View window header.

Orthographic vs. PerspectiveEdit

By default, viewports draw orthographic views. To toggle a viewport between orthographic and perspective views:

  1. Activate the 3D View window.
  2. Press  Num5 .

(If you're unsure what the difference is, please review the "Orthographic Views" module and the "Perspective Views" module.)

Note this perspective versus orthographic setting for the 3D viewport is completely separate from the similar setting in the camera properties; the former takes effect while you’re working on the model, the latter when you render.

So why have this separate setting for the 3D view? It’s because, regardless of what you want for the final render, certain aspects of modelling are easier in one view than another. If the final render will be using perspective, then naturally showing perspective in the 3D view gives you a better idea of how the final render will look. But perspective foreshortening can sometimes make it hard to ensure the model has the proper shape, which is why there is the option to flip to orthographic view if it helps.

If you have trouble distinguishing between orthographic view and perspective view

... you should activate the View Name option. This is enabled by default and causes the name of the current view ("User Persp", for instance) to appear in the upper left corner of every viewport. If there is no text, then you can enable it by:

  1. Accessing the User Preferences window.
  2. Click on the Interface tab.
  3. Enable View Name.

Changing Your Viewpoint, Part OneEdit

Each viewport has a viewpoint, which takes into account:

  • the location of the viewer in the 3D scene (There doesn't need to be an object at that location.)
  • the direction the viewer is looking
  • the magnification (or zoom factor) used

Changing your viewpoint allows you to navigate your way through a 3D scene.

We'll start with three very basic techniques:

  • Zooming
  • Orbiting/View Rotation
  • Perfect Views.

Additional techniques will be covered later in this module.

ZoomingEdit

Blender offers several ways to zoom in and out:

  • Use  SCROLL 
  • Click and drag vertically with  Ctrl + MMB .
  • Use  Num+  and  NUM−  to zoom in and out in small increments.

Note the following limitations of Blender's zoom feature:

  • If the viewport is in orthographic mode, Blender zooms as if looking through a telescope. You can increase the magnification, but the viewpoint's location doesn't change. For this reason, you cannot zoom into or through objects in orthographic mode.
  • If the viewport is in perspective mode, Blender zooms to a point—namely the center of the viewport. The viewpoint can pass through objects, but it can't pass beyond this point, no matter what you do. Zooming only gets slower and slower and slower. If the center of the viewport is somewhere you don't expect, zooming may appear to be broken.

Orbiting and View RotationEdit

Let's fly around in the default cube, viewing it from different angles. In this way you'll see that it really is a cube, centered on the origin, half above the X-Y plane and half below it.

  1. Activate the 3D View window by placing the mouse pointer inside it.
  2. Now you can:
    • Click and drag with  MMB  to orbit freely around the center of the view.
    • Use  Shift + Alt + SCROLL  to rotate the viewpoint vertically around the center of the view.
    • Use  Num2  and  Num8  to rotate the viewpoint vertically around the center of the view in 15-degree increments.
    • Use  Ctrl + Alt + SCROLL  to rotate the viewpoint around the Z axis.
    • Use  Num4  and  Num6  to rotate the viewpoint around the Z axis in 15-degree increments.

If this is all very confusing for you, don't worry! You'll learn as you get more experience.

When you are finished flying around the cube, you can restore the original view by reloading the factory settings with File → Load Factory Settings.

If the hotkeys don't work...

You may have pressed number keys above the letters instead of the ones on the numpad. If you do so, the default cube will vanish. This is because the scene consists of multiple layers. The default cube is in layer 1, and you've told Blender to switch to another layer of the number you just pressed. The selected object (the cube in this case) remains in layer 1, which isn't shown anymore. For instance,  2Key  tells Blender to switch to layer 2. To switch to layer 1 again, press  1Key . You can view the different layers by clicking on the little squares on the layer map: Blender-2.5 layers.png

Note:

Because the center of the viewport is invisible (not marked in any way), it's hard to tell where it is. This sometimes results in unexpected behavior during rotation.

 

Perfect ViewsEdit

It's often useful to get a perfect view of a scene—in other words, to view it along one of the main axes, with the other two main axes oriented up-down and left-right.

Perfect View Hotkeys
Hotkey View Axis Pointing Right Axis Pointing Up
 Num7  "top" +X +Y
 Ctrl + Num7  "bottom" +X -Y
 Num1  "front" +X +Z
 Ctrl + Num1  "rear" -X +Z
 Num3  "right side" +Y +Z
 Ctrl + Num3  "left side" -Y +Z

The following screenshot shows all three perfect views plus camera perspective for the Suzanne primitive:

Blender-2.5 perfect view quad.png

In fact, this layout of four viewports showing top, front and right views plus camera view is so commonly used that it has its own menu item (from the “View” menu, select “Toggle Quad View”) and keyboard shortcut ( CTRL + ALT + Q ).

Positioning the 3D CursorEdit

Positioning the 3D cursor is a very basic operation, yet one that many beginners find challenging. It touches on an issue common to all 3D graphics software: "How do you specify points in a 3D scene when we can only see two dimensions at a time?"

Basic TechniqueEdit

  1. Go into either Object Mode or Edit Mode.
  2. Move the mouse pointer to the desired position (in any viewport).
  3. Click  LMB .

Two ChallengesEdit

Challenge #1. Using only tools presented thus far, try positioning the 3D cursor on the virtual camera.

Try it!

When you're done, check your work by orbiting the camera.

Perhaps you thought you were done when you clicked on the camera. But the moment you changed your viewpoint, you probably found that the 3D cursor was actually behind (or in front of) the camera.

Hints:

  • Try positioning the cursor in two different perfect views.
  • Use orthographic views, not perspective ones.

Challenge #2. Using only tools presented thus far, try repositioning the 3D cursor at the origin (that is, at the center of the cube).

As before, check your work by orbiting the cube. Don't spend too much time on this.

User Comments

"I found that I would select the cube when left clicking on it in object mode, if the "Use 3d transform manipulator" button was enabled. To toggle this off, you click on the gray pointing hand in the 3d panel header, or (Ctrl Space)."

"When you want the cursor back into the cube, just select the camera with RMB, put the cursor into the cube following the steps above, and re-select the cube with RMB."

"I've discovered it helps a lot if you are in Object Mode and not in Edit Mode. I wrote the following before discovering this: The problem with this exercise, for me, is that left clicking on the cube selects the cube instead of moving the 3d cursor. If I click on the cube outside of its central white circle I can get the cursor to move there, but only to outside of this white circle, and even then this only works sometimes."

"I failed at this until I had zoomed in close enough to the cube. When I was too far zoomed out I kept selecting the cube rather than creating an edit point."

"I had the same problem and found it was because the cube was selected. I made sure I was in object mode, right clicked on the camera to select the camera instead of the cube, and I could then position the edit point in the cube. However, doing this messed up the next part of the tutorial because you cannot switch into edit mode with the camera selected! Perhaps the suggestion of trying to put the 3D cursor in the cube should be dropped as it raises too many questions at this stage."

"You can deselect all by pressing the AKEY or the select button in the 3D View."

"Use wireframe mode works better to get the cursor in."

"To get it back in the cube: 1) Make sure you're in object mode. 2) Select the cube. 3) Object > Snap > Cursor to selection (cursor refers to the 3D cursor here) so it puts it right in the middle of the cube."

"I think it's an essential point to note that in order to place the cursor inside the cube, the cube must NOT be selected. AKEY was probably the best way to deselect the object."

"If I remember correctly, undo history gets cleared when you switch between object and edit mode."

"I wasted a lot of time here. Thank you to the reader who suggested (on the 3D view header) Object > Snap > Cursor to selection. It was the only thing that worked to get the cursor visible again and placed where clicked."

"I missed the point of the exercise first time around. You can't set a 3D point on a 2D screen without technique. Orthographic views are crucial. I am just learning, but take that, at least, away from it."

More Ways to Position the CursorEdit

Blender-2.5 snap menu.png

Here's an easy way to position the cursor at the center of an object:

  1. Make sure Blender is in Object Mode, with the object selected.
  2. Move the mouse pointer to any 3D View window.
  3. Snap the cursor to the selected object using either:
    •  Shift + S  Cursor to Selected
    or
    • Object → Snap → Cursor to Selected

Here's 2 easy ways to relocate the cursor to the scene's origin (0, 0, 0):

  1. Move the mouse pointer to any 3D View window.
  2. Press  Shift + C  to reset the cursor to the origin.
    • Note that this also changes the view location, meaning that when you zoom in, you won't zoom in to the scene origin.
  3. A better way is to click Object → Snap → Cursor to Center
    • You can also do this by  Shift + S Cursor to Center.

Changing Your Viewpoint, Part TwoEdit

Now you'll learn some additional techniques for obtaining the view you want:

  • Panning
  • Centering
  • Jumping to the camera's viewpoint
  • Zooming in on a selected area

PanningEdit

When you orbited the cube, the viewpoint's position and direction both changed at the same time. You also can shift the viewpoint up-down or left-right without changing its direction. (This is similar to the side-scrolling effect in the classic Mario and Sonic video games.)

This is called panning, and it's an important skill to master. Try it now:

  1. Activate a 3D View window by placing the mouse pointer inside it.
  2. Now you can:
    • Use  Shift + SCROLL  to pan up and down.
    • Use  Ctrl + Num2  and  Ctrl + Num8  to pan up and down in small increments.
    • Use  Ctrl + SCROLL  to pan left and right.
    • Use  Ctrl + Num4  and  Ctrl + Num6  to pan left and right in small increments.
    • Click and drag with  Shift + MMB  or  Shift + Alt + LMB  to pan freely in the viewplane.


You will likely find this to be a distraction in some cases. To move the viewpoint position back to the center, snap the cursor to the center, then click View → Align View → Center View to Cursor. You could also snap the cursor to the center then press  Ctrl + Num. .

CenteringEdit

When you zoom or rotate the view, you always zoom or rotate around the center of the view.

To center the view on an arbitrary point:

  1. Move the 3D cursor to the point of interest.
  2. Verify the cursor position from a second viewpoint.
  3. Press  Alt + Home  to center the view.

To center the view on an object in the scene:

  1. Make sure Blender is in Object Mode.
  2. Zoom out until the object is in the viewport.
  3. If any objects are selected, use  A  (or Select → Select/Deselect All) to deselect them.
  4. Select the object of interest by clicking  RMB  on it.
  5. Press  Num.  to center the view.

Jumping to the Camera's ViewpointEdit

To see the scene as the virtual camera sees it, press  Num0 . Afterwards, you can rotate, pan, and zoom normally, but the virtual camera will not follow. To go back to your previous view, press  Num0  again. (In the latest versions of Blender, the virtual camera can be made to follow all the changes made in viewpoint while in camera view by checking the option "Lock Camera to View" on the Transform panel. Hit "N" on your keyboard to bring the transform panel. To disable this option you can uncheck that and get back to previous settings.)

Zooming into a Selected AreaEdit

Suppose you want to get an extreme closeup of a particular area. Because there's no center mark on the viewport, you might have to pan and zoom several times to get the desired view.

The shortcut for zooming to an area is:

  1. Activate a 3D view window that contains the area of interest.
  2. Press  Shift + B . A crosshair appears in the viewport.
  3. Click and drag with  LMB  to draw a rectangle around the area of interest.
  4. When you release  LMB , the viewport will zoom in on the area you selected.

Fly ModeEdit

Another way of changing your viewpoint in the 3D view is with “Fly Mode”. To activate this, press  SHIFT + F . Now you can use the mouse wheel to apply forward and backward “thrust”: scroll up to accelerate forwards, scroll down to accelerate backwards, and leave the wheel alone to coast at constant speed. Also move the mouse (without pressing any buttons) to alter your orientation, up, down, left or right (the velocity vector will stay parallel to your forward/backward axis).

When you have reached the position and orientation you want, press  LMB  or  ENTER  to exit Fly Mode and stay there, or  RMB  or  ESC  to exit Fly Mode and be teleported immediately back to your original position and orientation.

Visibility LayersEdit

Every object in the scene is assigned to one of 20 visibility layers.

Visibility layers have many uses:

  • You can put scenery, characters, particles, and lamps in different layers, to help organize your scene.
  • By changing which layers are visible, you can simplify your view of the scene and work with only one or two layers at a time.
  • When rendering, only visible layers are included. You can use this to render your scene layer by layer, checking each layer separately.
  • You can configure lamps to illuminate only objects in the same layer.
Left: Viewing layer 1 only.
Right: Viewing all 20 layers.

In Object Mode, you can tell which layers are visible by looking at the twenty small boxes located in the 3D View header between the Transform Orientation menu and the "Lock" button. The top row of boxes represents layers 1 through 10, with 1 being the leftmost and 10 being the rightmost. Similarly, the bottom row of boxes represents layers 11 through 20.

HotkeysEdit

  • To view just one of layers 1 .. 9, press  1KEY  ..  9KEY .
  • To view just layer 10, press  0Key .
  • To view just one of layers 11 .. 19, press  ALT + 1KEY  ..  ALT + 9KEY 
  • To view just layer 20, press  ALT + 0KEY .
  • To toggle the visibility of one of layers 1 .. 9 without affecting the visibility of the other layers, press  SHIFT + 1KEY  ..  SHIFT + 9KEY .
  • To toggle the visibility of layer 10 without affecting the visibility of the other layers, press  SHIFT + 0KEY .
  • To toggle the visibility of one of layers 11 .. 19 without affecting the visibility of the other layers, press  ALT + SHIFT + 1KEY  ..  ALT + SHIFT + 9KEY .
  • To toggle the visibility of layer 20 without affecting the visibility of the other layers, press  ALT + SHIFT + 0KEY .
  • To make all layers visible at once, press  ~ . Press  ~  again to return to your previous layer visibility setting.
Note:

The hotkeys in this section will not work if you've enabled numpad emulation in the User Preferences window. See the "User Preferences Windows" module for more details.

 

Note to AZERTY users:

On the AZERTY keyboard layout, the standard number keys are the &é"'(-è_çà keys. Do not use  Shift  unless you want to toggle visibility as explained below.


Holding down  Shift  while selecting a layer (by keyboard or mouse) will, instead of making only that layer visible, toggle the visibility. In this way, you can select combinations or to hide particular layers.

The key to press to select all layers at once differs by keyboard layout. It is:

  •  ¬'  (the key under Esc) on UK keyboards,
  •  `~  on US ones,
  •  ö  on German, Swedish and Finnish ones,
  •  æ  on Danish ones,
  •  ù  on AZERTY ones,
  •  ø  on Norwegian ones,
  •  Ñ  on Spanish ones,
  •  "  on Brazilian Portuguese ones, and
  •  ò  on Italian ones.

After pressing the aforementioned key, holding down  Shift  while pressing it again will restore the visibility settings you had before you made all layers visible.

When only one layer is selected, new objects are automatically assigned to that layer. When two or more layers are visible, new objects are assigned to the layer that became visible most recently.

Count Your PolysEdit

If you want to count the polygons in your scene, this data is available in the Info Header.

Blender-2.5 polycount.png

As you can see in the above image, this scene has 507 vertices and 500 faces (polygons).

Last modified on 16 November 2013, at 22:38